Opened 9 years ago

Closed 7 years ago

Last modified 5 years ago

#5779 closed Bug (fixed)

can't edit fields in jQuery UI modal dialog

Reported by: psyafter Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version: 4.0.1
Keywords: HasPatch Cc: me@…

Description

I have a trouble with CKEditor about 1 year (all last versions from 3.0 till new version 3.3)

When I use ckeditor in "jQuery UI modal dialog" ( http://jqueryui.com/demos/dialog/#modal ) and try edit some properties of table (already created before) - so for example I can't edit numbers of rows and cells (both fields are disabled).

The same situation when I try edit alternate text in image window.

It's normal situation or it's a bug?

Attachments (1)

ckInJQueryDialog.html (3.9 KB) - added by Jakub Ś 8 years ago.

Download all attachments as: .zip

Change History (18)

comment:1 Changed 9 years ago by psyafter

Version: 3.3

comment:2 Changed 9 years ago by Garry Yao

Keywords: Pending added

Would you please attach an sample page with jqUI for us to make any judgement?

comment:3 Changed 9 years ago by psyafter

yes, of course.

I was update sample page and uploaded it to test domain (with ckeditor files and jQuery + UI).

There is link to page: http://pmp.psymind.info/ckeditor/ajax.html

1) Open the dialog 2) Click on CreateEditor 3) Try to create table and edit rows/cell or any other field. It's disabled for editing. Same situation in creating image (editing alternate text)

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added; Pending removed
Version: 3.33.0

Weird thing... much probably jQuery UI is catching the keystrokes.

comment:5 Changed 9 years ago by psyafter

That will do solution for this situation?

comment:6 Changed 8 years ago by Jose S

Cc: me@… added
Component: GeneralUI : Dialogs
Version: 3.03.5

Verified on jQuery UI 1.8.5 and CKEditor 3.5 and not work focus dialog input. No z-index found.

comment:7 Changed 8 years ago by Jakub Ś

I have checked this issue with latest jQuery UI 1.8.16, jQuery 1.6.4 and CKEditor 3.6.2.

Problem still occurs in IE7, Webkit and Opera (E.g. fields in cell properties dialog are not editable).

Changed 8 years ago by Jakub Ś

Attachment: ckInJQueryDialog.html added

comment:8 Changed 7 years ago by rcjusto

I could solve this, adding some lines in file "dialog.css" for the active skin, to setting all inputs in dialogs with position: relative and z-index: 9999.

.cke_skin_v2 input.cke_dialog_ui_input_text, .cke_skin_v2 input.cke_dialog_ui_input_password {
    background-color: white;
    border: none;
    padding: 0;
    width: 100%;
    height: 14px;
    /* new lines */
    position: relative;
    z-index: 9999;
}

The problem is caused by zIndex() function in jQueryUI library. That function only get the z-index property correctly if the object has absolute, relative or fixed position. This function is used in ui-dialog to validate what controls can gain the focus, when the dialog is modal.

Sorry by my english, I hope this can help someone.

comment:9 Changed 7 years ago by Jakub Ś

Keywords: HasPatch added

@rcjusto thank you for the patch. Those two lines seem to fix the issue.

NOTE: The solution from #8443 (config.baseFloatZIndex = 102000;) does not work in this case.

comment:10 Changed 7 years ago by Andy Watson

rcjusto's patch worked for us too.

Unfortunately this doesn't seem to have been 'fixed' or patched into the latest release of ckeditor for download on the main website. We spent 2 hours trying to track this problem down finally landing here. Will this be added to the release version?

Last edited 7 years ago by Andy Watson (previous) (diff)

comment:11 Changed 7 years ago by Jakub Ś

Seems that this issue got fixed on trunk with rev. [7512]. Despite problems caused by this revision #9060 and fix for it provided in rev. [7524], it seems that good changes have stayed and this issue has expired on trunk.

comment:12 Changed 7 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

Checked that once more seems that issue got fixed with CKEditor 3.6.4 rev. [7512]

comment:13 Changed 6 years ago by psyafter

Version: 3.54.0.1

comment:14 Changed 6 years ago by psyafter

This bug present in version

  • cke 4.0.1
  • jquery.adapter
  • jquery-1.9.1
  • jqury-ui-1.10.0

comment:15 Changed 6 years ago by Oskar

Created this ticket https://dev.ckeditor.com/ticket/10086. Have the same problem with

  • cke 4.0.1
  • jquery-1.8.3
  • jqury-ui-1.10.0

comment:16 Changed 5 years ago by Chad

Here is an example when we have buttons in the modal window and they work fine, maybe it can help: http://basicuse.net/articles/pl/scripting_languages/javascript/jquery_ui_widgets_dialog_windows

comment:17 Changed 5 years ago by Jakub Ś

I think the best workaround is using e.g. jqury-ui-1.9.2 ( something below jqury-ui-1.10.0).

As mentioned in #10269, jqury-ui-1.10.0 has introduced some new problems.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy