Opened 7 years ago

Last modified 4 years ago

#9821 confirmed Bug

ALT+F key combinations do not work on Mac

Reported by: Sa'ar Zac Elias Owned by:
Priority: Normal Milestone:
Component: Documentation & Samples Version:
Keywords: Cc:

Description

On Mac, ALT+F10 and ALT+F11 open the sound settings menu instead of the anticipated CKEditor accessibility features.
Tested on Macs with OS X Mountain Lion (10.8.2) and standard Apple keyboards (where F10 and F11 control the sound).

Change History (9)

comment:1 Changed 7 years ago by Piotrek Koszuliński

Resolution: invalid
Status: newclosed

If F10 and F11 control the sound, then you need to use them with Fn key (so ALT+FN+F10), to trigger correct keystroke. This is normal behaviour.

comment:2 Changed 7 years ago by Piotrek Koszuliński

You can also change keyboard settings so function keys work without Fn pressed. Then ALT+F10 will to its job.

comment:3 Changed 7 years ago by Wiktor Walc

Resolution: invalid
Status: closedreopened

This should be at least documented properly (accessibility help, docs etc.), as it looks like it's confusing: see another user who had problems with it

Last edited 7 years ago by Jakub Ś (previous) (diff)

comment:4 Changed 7 years ago by Mike Gifford

comment:5 Changed 7 years ago by Jakub Ś

Status: reopenedconfirmed

comment:6 Changed 7 years ago by Jakub Ś

Component: AccessibilityDocumentation & Samples

comment:7 Changed 6 years ago by Jakub Ś

I was convinced that we have different shortcuts assigned based on OS but it seems that this isn't the case as we have other issues of that kind: #10015, #11916.

comment:8 Changed 4 years ago by Piotrek Koszuliński

I agree that this may be confusing, especially for Mac users because MacOS doesn't have any keystrokes using F-keys.

It was also pointed out that using ALT+FN+F0/10/11 keystrokes may be hard for people with disabilities, because it requires pressing 3 keys at the same time. That's true. But I think that the solution is to configure MacOS to not require pressing the FN key (such option of course exists). Such options should also be available in other systems.

So, basically, our problem is only that this problem isn't mentioned anywhere in our docs.

I would consider adding a short section about using F-keys with FN, and about FN-key lock in:

comment:9 Changed 4 years ago by Mike Gifford

Can it be added to the help within CKEditor? Would be nice it was user facing & not something that you'd have to google for.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy