Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9830 closed Bug (worksforme)

CKEditor 4 does not load when the Google Chrome developer tools are open before loading the page

Reported by: Wim Leers Owned by:
Priority: Normal Milestone:
Component: UI : Toolbar Version: 4.0.1
Keywords: Cc:

Description

(I hope I selected the right properties. First ticket that I'm opening here!)

Attachments (2)

CKEditor 4 does not load.mov (2.2 MB) - added by Wim Leers 6 years ago.
Dev Tools Settings - UA.png (92.1 KB) - added by Frederico Caldeira Knabben 6 years ago.

Change History (12)

comment:1 Changed 6 years ago by Nico Burns

This works fine for me (tested Chrome 23.0.1271.97/windows and 25.0.1359.3/windows).

I find that sometimes pages don't load properly in Chrome if you try to navigate to them too soon after opening the dev tools. Could that be it?

Which operating system are you using? And do you have any extensions which could be interfering? (you can check this by temporarily disabling them, or opening the page in incognito mode)

Last edited 6 years ago by Nico Burns (previous) (diff)

comment:2 Changed 6 years ago by Piotrek Koszuliński

Status: newpending

WFM too. Chrome 23.0.1271.95 on Ubuntu.

comment:3 Changed 6 years ago by Frederico Caldeira Knabben

:/ wfm as well: Chrome 23.0.1271.97 Mac.

I'm sure you're not having js errors (you would have reported them), so can you check if you have any pending request in the Network tab of the dev tools?

Also, does it happen with the nightly build or even locally with the editor samples?

Changed 6 years ago by Wim Leers

comment:4 Changed 6 years ago by Wim Leers

comment:1, comment:2, comment:3 — very odd!

I'm sure I'm not getting any JS errors, nor are there any pending network requests, and it also happens with the nightly build. I recorded a quick screencast for you; see the video I attached.

comment:5 Changed 6 years ago by Frederico Caldeira Knabben

wfm with that very same Chrome version and Mountain Lion. Works for everybody I've asked to test it as well.

Further research:

  1. Can you confirm it on any other machine?
  2. Do you have the same in a Incognito Window?
  3. I hope that "2" is "No!"... in that case, what are your enabled Chrome extensions?
  4. Can you reinstall MacOS and check if it helps?... just kidding :D

comment:6 Changed 6 years ago by Wim Leers

WTF!

  1. Yes. Personal machine: 10.7.3. Work machine: 10.7.4. Same results.
  2. I can no longer reproduce this once I use an Incognito Window…
  3. I disabled all Chrome extensions and was still able to reproduce it.
  4. Hah! My heart skipped a beat :P

This is very weird. Since it works fine for everybody except for me, please just don't spend any more time on it. I guess something is goofy about my Chrome…

comment:7 Changed 6 years ago by Piotrek Koszuliński

Resolution: worksforme
Status: pendingclosed

My last idea - haven't you changed some settings in Chrome Dev Tools? E.g. that it pauses on all errors?

Anyway - closing :).

comment:8 Changed 6 years ago by Wim Leers

So now that I'm starting to develop things around CKEditor, this is actually an absolute nightmare. CKEDITOR.replace returns null when the dev tools are open, yet returns an editor instance when the inspector is closed.

Even when the dev tools were first open, then closed, and then I try to call CKEDITOR.replace(), it will still fail (return null).

Changed 6 years ago by Frederico Caldeira Knabben

Attachment: Dev Tools Settings - UA.png added

comment:9 Changed 6 years ago by Frederico Caldeira Knabben

I know... this can be a pain.

I was able to reproduce the problem exactly as you have it... but I had to change the dev tools setting for it, to override the UA string:

Are you sure you have default setting there?

comment:10 Changed 6 years ago by Wim Leers

I just went ahead and reset all my Chrome settings. Now it works. I did not have a User Agent setting anymore, though I did at one time; so maybe Chrome had messed up some internal setting.


Just to verify whether what you just described in comment:9 could also trigger it, I configured it that way, and indeed, it triggers the same behavior! Hopefully this will be of use to somebody else with similar problems in the future :)

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy