Opened 6 years ago

Closed 6 years ago

#9845 closed Bug (fixed)

Focus goes out of Link dialog when there are no Anchors

Reported by: Satya Minnekanti Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 4.0.2
Component: General Version: 4.0 Beta
Keywords: IBM Cc: Damian, Teresa Monahan

Description

To reproduce the defect:

  1. with JAWS on, Open any CK Editor sample, navigate in to Editor body.
  1. Press Alt + F10 to navigate to toolbar.
  1. Navigate to Link icon and press Enter.
  1. In the Link dialog, Navigate to Link Type combo box & select Link to anchor in the text option.
  1. Press Tab

Expected Result: Focus goes to error message div which says No anchors available in the document & JAWS reads that error message.

Actual Result: Focus goes to window & JAWS reads AJAX M CK Editor Sample button in AJAX Sample

This is happening only in 4.0 build & not in 3.6.5 stream

Change History (8)

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed
Version: 4.04.0 Beta

Problem can be reproduced from CKEditor 4 beta.

NOTE: It doesn't matter which skin you are using.

comment:2 Changed 6 years ago by Jakub Ś

#9919 was marked as duplicate.

comment:3 Changed 6 years ago by Frederico Caldeira Knabben

This issue is caused by git:47f8446. I've reverted it and it started working, but we still need to understand the reasoning behind that change.

comment:4 Changed 6 years ago by Frederico Caldeira Knabben

git:47f8446 exists because of this TC with Firefox:

  1. Open inline sample.
  2. Place cursor inside editor.
  3. Click one of "paste" buttons.
  4. Paste or write something.
  5. Accept/cancel.
  6. There's no toolbar.

comment:5 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.0.2
Owner: set to Frederico Caldeira Knabben
Status: confirmedreview

Created t/9845. I've reverted git:47f8446 and introduced a new way to avoid the above tc.

comment:6 Changed 6 years ago by Olek Nowodziński

Rebased branch to latest master.

comment:7 Changed 6 years ago by Olek Nowodziński

Status: reviewreview_passed

Pushed a commit to collapse the solution into a single LOC.

comment:8 Changed 6 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: review_passedclosed

Fixed with git:da2dbb2.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy