Opened 7 years ago

Closed 7 years ago

#9866 closed Bug (fixed)

[IE10] The full toolbar is displayed in two lines in RTL environment

Reported by: Wiktor Walc Owned by: Wiktor Walc
Priority: Normal Milestone: CKEditor 3.6.6
Component: UI : Toolbar Version: 3.4.3
Keywords: IE10 Cc:

Description (last modified by Wiktor Walc)

See the attached screenshot (Hebrew language was selected)

  1. Open _samples/ui_languages.html
  2. Select Hebrew language

The monitor must be wide enough to see the issue.

Reproduced in 3.6.6(SVN), happens at least since 3.5 (previous versions did not load at all). I was unable to confirm it in 4.0.

Attachments (5)

rtl_toolbar.png (24.4 KB) - added by Wiktor Walc 7 years ago.
rtl_v2.png (13.8 KB) - added by Wiktor Walc 7 years ago.
rtl_office2003.png (18.8 KB) - added by Wiktor Walc 7 years ago.
9866.patch (2.9 KB) - added by Wiktor Walc 7 years ago.
9866_3.patch (3.0 KB) - added by Wiktor Walc 7 years ago.

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by Wiktor Walc

Attachment: rtl_toolbar.png added

comment:1 Changed 7 years ago by Wiktor Walc

Description: modified (diff)
Version: 3.5

Changed 7 years ago by Wiktor Walc

Attachment: rtl_v2.png added

Changed 7 years ago by Wiktor Walc

Attachment: rtl_office2003.png added

comment:2 Changed 7 years ago by Jakub Ś

Keywords: IE10 added; IE removed
Status: newconfirmed
Version: 3.53.4.3

I have managed to reproduce this only in IE10 from CKEditor 3.4.3. Before this version, just like @wwalc has described, content area doesn't load because of toLowercase error.

I was not able to reproduce this in CKE 4.x (v4).

Changed 7 years ago by Wiktor Walc

Attachment: 9866.patch added

comment:3 Changed 7 years ago by Wiktor Walc

Owner: set to Wiktor Walc
Status: confirmedreview

comment:4 Changed 7 years ago by Jakub Ś

I have just applied the patch, set 'he' language and got 3 lines as expected in all skins.

comment:5 Changed 7 years ago by Jakub Ś

It seems that IE10 is breaking with modes set by meta tags:

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
<meta http-equiv="X-UA-Compatible" content="IE=7" />
<meta http-equiv="X-UA-Compatible" content="IE=8" />

NOTE: 7 and * modes require just loading the page. In EmulateIE7 you need to press Crtl+F5 few times quickly to see the effect.

Changed 7 years ago by Wiktor Walc

Attachment: 9866_3.patch added

comment:6 Changed 7 years ago by Wiktor Walc

Milestone: CKEditor 3.6.6
Resolution: fixed
Status: reviewclosed

Fixed with [7685].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy