Opened 7 years ago

Closed 7 years ago

#9940 closed Bug (fixed)

Firefox, going back makes full page editable

Reported by: Alfonso Martínez de Lizarrondo Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 4.0.2
Component: General Version: 4.0
Keywords: Cc:

Description

Login to CKEditor forums and go to http://ckeditor.com/forums/CKEditor/Update-Value-Rich-Combo-when-adding-a-value-in-a-text-box-external-to-CKeditor-with with Firefox (Tested Aurora 19.0a2)

Click on one of the attachments to view the image

Click the toolbar "back" button.

Wait a little and you'll see that the full page now is editable. The culprit seems to be the

onpageshow=event.persisted&&(function(){var x=CKEDITOR.instances,d,i;for(i in x){d=x[i].document;if(d){d.$.designMode="off";d.$.designMode="on";}}})();
}}} on the body.

Change History (4)

comment:1 Changed 7 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.0.2
Status: newconfirmed

WAT :|

It may be related to #9883 - another WAT.

comment:2 Changed 7 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: confirmedreview

This has nothing to do with #9883.

It is related to a fix made for #4514, which seems to not be necessary any more. Therefore I'm just reverting that fix in t/9940@cksource.

comment:3 Changed 7 years ago by Olek Nowodziński

Status: reviewreview_passed

comment:4 Changed 7 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: review_passedclosed

Fixed with git:a49965b.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy