Opened 7 years ago

Closed 5 years ago

#9946 closed Bug (duplicate)

Tableresize tools try to resize tables outside of the editor

Reported by: Michiel Overeem Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0 Beta
Keywords: Cc:

Description

The tableresize plugin does not check if the table is part of the current contenteditable element.

The workaround is to add the following line to the mousemove eventhandler:

if(!table || table.getAscendant("div", 1).$ != b.element.$)
  return;

Attachments (2)

ckeditor-tableresize.swf (2.2 MB) - added by Michiel Overeem 7 years ago.
Screencapture of the sample page with the problem present
tabresizeproblem.html (1.7 KB) - added by Jakub Ś 7 years ago.
Sample to illustrate the problem

Change History (8)

comment:1 Changed 7 years ago by Jakub Ś

Keywords: tableresize removed
Status: newpending

Could you please provide reduced html sample (something like sample page that can be put in samples folder) that shows the problem.

You have shown us some solution but what exactly is happening? How can this be observed in editor? Is this any problem that you can see or perhaps you had problems with your custom code and this is the solution you have come up with?

Please provide sample (if possible) and detailed explanation.

comment:2 Changed 7 years ago by Michiel Overeem

In this sample you will see that you can resize the table columns in which the ckeditor is nested. Move your mouse over the edges of the editor (they collapse with the table borders) and you will see the cursor change. I do not think there is a conflict with custom code. The problem is that the tableresize plugin uses the following code:

if ( !target.is( 'table' ) && !target.getAscendant( 'tbody', 1 ) )
  return;
table = target.getAscendant( 'table', 1 );

You see that there is no check to make sure we are looking at a table within the contenteditable part.

comment:3 Changed 7 years ago by Jakub Ś

In this sample you will see that you can resize the table columns in which the ckeditor is nested.

I'm sorry but despite many tries I was not able to reproduce this. I was hovering, clicking etc. and was not able to reproduce this problem in latest editor.

If this is not too much to ask could I ask you to provide sample screen cast that shows how to reproduce this problem?

You have written:

I do not think there is a conflict with custom code.

Does it mean that you have customized editor? If yes, have you perhaps tried this sample in fresh CKEditor without any customizations?

Changed 7 years ago by Michiel Overeem

Attachment: ckeditor-tableresize.swf added

Screencapture of the sample page with the problem present

comment:4 Changed 7 years ago by Michiel Overeem

Attached you will find the screen capture.

I've put the attached sample page in the samples directory of the downloaded ckeditor-version. So I know for sure that there is no custom-code present that can cause conflicts.

You can see in the screencapture that the tableresize cursor becomes visible on the edges of the editor-element. This is caused by the outer table.

comment:5 Changed 7 years ago by Jakub Ś

Status: pendingconfirmed
Version: 4.0.14.0 Beta

@michielovereem I was able to reproduce this problem only when I have modified editor to contain {extraPlugins: 'tableresize'} .

I have attached modified sample.

Problem can be reproduced in all browsers from CKEditor 4.0 beta.

Changed 7 years ago by Jakub Ś

Attachment: tabresizeproblem.html added

Sample to illustrate the problem

comment:6 Changed 5 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

@michielovereem I'm closing this ticket as duplicate of #11603. The later one has pull request assigned I will however ask if this solution can be checked as well.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy