Opened 6 years ago

Closed 6 years ago

#9990 closed New Feature (fixed)

Dialogs integration with allowed content filter

Reported by: Piotrek Koszuliński Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.1 RC
Component: General Version:
Keywords: Drupal Cc: wim.leers@…

Description (last modified by Piotrek Koszuliński)

Extracted from #9829 point 3.

Developers can define this configuration. At that point, plugins, or part of their features, get enabled/disabled based on the configuration.

Allowed content setting should affect which dialog's inputs are displayed.

http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-removeDialogTabs should affect at least plugins which implements 'advanced' tab.

Change History (9)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Status: newconfirmed

comment:2 Changed 6 years ago by Piotrek Koszuliński

Description: modified (diff)

comment:3 Changed 6 years ago by Piotrek Koszuliński

Type: BugNew Feature

comment:4 Changed 6 years ago by Piotrek Koszuliński

Description: modified (diff)

comment:5 Changed 6 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:6 Changed 6 years ago by Piotrek Koszuliński

Status: assignedreview

Pushed t/9990 and t/9990@tests (both based on t/9829).

I skipped form dialogs integration, because of number of them and low importance. Other dialogs should be well integrated.

Last edited 6 years ago by Piotrek Koszuliński (previous) (diff)

comment:7 Changed 6 years ago by Piotrek Koszuliński

Rebased branches on major.

comment:8 Changed 6 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:9 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Merged to major on git:c7cf983 on dev and 43ddcc2 on tests.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy