Ticket #7896 (closed Bug: fixed)

Opened 4 years ago

Last modified 3 years ago

IE: table cell properties giving error undefined (table tools, onshow invalid selection) when enterMode = CKEDITOR.ENTER_BR

Reported by: svanlang Owned by: garry.yao
Priority: Normal Milestone:
Component: General Version: 3.5.3
Keywords: IE IBM Cc: contact@…, satya_minnekanti@…, scalvert@…

Description

Steps to reproduce:

Set config.enterMode = CKEDITOR.ENTER_BR; create a table. click into a single cell, use contextmenu / cell /cellproperties

The error in browser is in tabletools\plugin.js on row 14 where seletion is empty. Fired in tableCell.js onShow(line 504) were this._.editor.getSelection() gives no result.

this only happens in IE. I cannot reproduce this in firefox. tested in IE8/IE7/IE9

Only when enter mode is set to BR.

Also tested on the nightly build. Still was the case.

Attachments

7896.patch (3.2 KB) - added by garry.yao 3 years ago.

Change History

comment:1 Changed 4 years ago by svanlang

I can reproduce this also in 3.5.4 and 3.5.3 I cannot reproduce this in 3.5.2

comment:2 Changed 4 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version changed from 3.6 to 3.5.3

True for IE7/8/9 from CKEditor 3.5.3 rev [6478].

The error from tableCell.js is:
Message: 'undefined' is null or not an object
Line: 223
Char: 13
URI: /_source/plugins/tabletools/dialogs/tableCell.js


The error in browser is in tabletools\plugin.js on row 14 where seletion is empty.

We had similar error with tabletools and line 14 #7529

comment:3 Changed 4 years ago by Saare

  • Cc contact@… added
  • Keywords IE added

comment:4 Changed 4 years ago by satya

  • Keywords IBM added
  • Cc satya_minnekanti@… added

comment:5 Changed 4 years ago by wwalc

  • Cc scalvert@… added

IE8:

  1. An error occurs when opening "Cell Properties":
    'null' is null or not an object  tabletools/plugin.js, line 14 character 3
    
    Note: in the elements path suddenly "h1" appears when dialog opens.
  1. After clicking "Ok"
    'length' is null or not an object tableCell.js, line 512 character 23
    
  1. Opening "Table Properties" results in:
    'null' is null or not an object table/dialogs/table.js, line 61 character 6
    
    After pressing "Ok" new table is inserted.

comment:6 Changed 3 years ago by garry.yao

  • Status changed from confirmed to assigned
  • Owner set to garry.yao

Affects all dialogs opening when cursor inside table cell, regression of [6698]

Last edited 3 years ago by garry.yao (previous) (diff)

Changed 3 years ago by garry.yao

comment:7 Changed 3 years ago by garry.yao

  • Status changed from assigned to review

#4385,#5221,#6629 should be checked.

comment:8 Changed 3 years ago by j.swiderski

  • Status changed from review to closed
  • Resolution set to fixed

The patch looks good but this issue is no longer reproducible in latest CKEditor 3.6.2

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy