Ticket #8493 (closed Bug: fixed)

Opened 3 years ago

Last modified 2 years ago

[IE] : Can't add link to selected text

Reported by: j.swiderski Owned by:
Priority: Normal Milestone: CKEditor 3.6.3
Component: General Version: 3.6.2
Keywords: IE HasPatch Cc: ruud@…

Description (last modified by j.swiderski) (diff)

In IE from CKEditor 3.6.2 it has been impossible to change selected text into link (Link is added next to text).

Steps to reproduce:

  1. Open http://www.ckeditor.com/demo
  2. Click the 'Code' button
  3. Replace all code by this HTML code:

<table><tr><td>test test test test</td></tr></table>

  1. Click the 'Code' button again
  2. Double-click the 2nd, 3rd or 4th word 'test' (if you select the first one, the problem doesn't occur).
  3. Click the Add Link button
  4. URL: google.com
  5. Click OK

Expected result:
The selected word is now a link to google.com

Actual result:
The selected word is not a link. The link to google.com is added in front of the selected word.

NOTE:If you undo (CTRL-Z) after step 8, and repeat step 5 t/m 8, the link is created as expected. So it seems to be a problem only the first time.

Issue has been reproducible in IE browsers from CKEditor 3.6.2 rev [7243].

Attachments

8719.patch (630 bytes) - added by j.swiderski 2 years ago.
patch proposed by @josephrider

Change History

comment:1 Changed 3 years ago by j.swiderski

  • Status changed from new to confirmed

comment:2 Changed 3 years ago by ruud_bmg

  • Cc ruud@… added

comment:3 Changed 3 years ago by j.swiderski

This may be a duplicate of #8475

Last edited 3 years ago by j.swiderski (previous) (diff)

comment:4 Changed 3 years ago by j.swiderski

#8546 was marked as duplicate

Another TC from the dulicate:

  1. Paste in the below code
    <ol> 
    <li id="uavklart">Pri 1: Utdanning.no: Vurdere om vi hvilket innhold&nbsp;vi ønsker å levere og hvordan - fortsatt manuelt, fra fs eller fra web eller SO</li> 
    </ol> 
    
  1. select word "om"
  2. add link to the selection

Result: link is added next to selection.

Expected Result: Selection should be changed into link.

comment:5 Changed 3 years ago by j.swiderski

#8567 was marked as duplicate.

comment:6 Changed 3 years ago by j.swiderski

TC from #8567

  1. Select some text that is in a bullet/numbered list
  2. Click on hyperlink icon
  3. Choose file from server (can be done on CKEditor demo where CKFinder is attached).
  4. URL should point to that file. Click OK.

comment:7 Changed 3 years ago by j.swiderski

  • Description modified (diff)

comment:8 Changed 3 years ago by wwalc

  • Milestone set to CKEditor 3.6.3

Creating links is a very basic and common operation, so let's fix this bug sooner than later.

comment:9 Changed 2 years ago by j.swiderski

#8719 was marked as duplicate

@josephrider has provided patch which I'm attaching to this ticket.
I did a quick test and this patch has solved this particular problem.

Changed 2 years ago by j.swiderski

patch proposed by @josephrider

comment:10 Changed 2 years ago by j.swiderski

  • Keywords HasPatch added

comment:11 Changed 2 years ago by j.swiderski

Other tickets caused by rev [7243]: #8455, #8475, #8632

comment:12 Changed 2 years ago by garry.yao

Supposed to be fixed by #8345, it shouldn't be related to [7243], pls check.

comment:13 Changed 2 years ago by j.swiderski

I have checked it one more time (followed exactly TC steps). Reproducible from [7243] and [7384] didn't fix it.

checked issue under [7394] but it still persists.

comment:14 Changed 2 years ago by garry.yao

Supposed to be fixed by #8632.

comment:15 Changed 2 years ago by j.swiderski

Seems that all three TC's mentioned here pass. Works as expected

comment:16 Changed 2 years ago by garry.yao

  • Status changed from confirmed to closed
  • Resolution set to fixed

Fixed by #8632.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy