Ticket #8523 (closed Bug: fixed)

Opened 3 years ago

Last modified 2 years ago

Changing colors not working with XHTML compliant code

Reported by: skifidelity Owned by:
Priority: Normal Milestone: CKEditor 3.6.3
Component: General Version: 3.2.1
Keywords: Cc:

Description

It is not possible to change the color twice, when using CKEditor in XHTML compliant mode. The bug can easily be reproduced on the demo site: http://nightly.ckeditor.com/7310/_samples/output_xhtml.html

Mark a word. Choose the blue color, which will work. Choosing a second color without unmarking the word will fail. This also makes it impossible to remove a chosen color.

Change History

comment:1 Changed 3 years ago by skifidelity

  • Keywords XHTML added

comment:2 Changed 3 years ago by j.swiderski

  • Status changed from new to confirmed
  • Keywords XHTML removed
  • Version set to 3.2.1

It is not possible to change the color twice

  1. This is true for Text color. Once the color is set it cannot be changed. Looks like new span tags wrap old ones.
  2. This is not true for text background color as every time you choose color new span tag with class wraps selected text and not old tags.

This also makes it impossible to remove a chosen color

  1. This is true for text and text background color. Choosing twice the same color results in:
    1. span around text for font color <span class="FontColor1">some</span>
    2. two spans around text for text background color <span class="FontColor1BG"><span class="FontColor1BG">some</span></span>

(Switching to Source and back and then applying colors can help to reproduce the issue)

  1. It is also not possible to remove/change colors using "Automatic color"
Last edited 3 years ago by j.swiderski (previous) (diff)

comment:3 Changed 3 years ago by j.swiderski

Tickets #6749 and #8679 are related.

comment:4 Changed 3 years ago by j.swiderski

#5960 is also related.

comment:5 Changed 2 years ago by j.swiderski

Other tickets that fall under Select "Color Dialog Problems / Enchancements":
#8706, #8698, #8519, #8679, #8701, #8218, #5960, #4994.

comment:6 Changed 2 years ago by alfonsoml

  • Status changed from confirmed to closed
  • Resolution set to fixed
  • Milestone set to CKEditor 3.6.3

This is fixed now with #7492.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy