Opened 6 years ago

Closed 6 years ago

#10119 closed Bug (fixed)

[FF] Click on "body" in elements path selects only on first block element

Reported by: Piotrek Koszuliński Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 4.0.2
Component: Core : Selection Version: 4.0.2
Keywords: Firefox Cc:

Description

TC1:

  1. Open replacebyclass sample.
  2. Without focusing editor, click 'body' in elements path.
  3. Only header and image were selected.

TC2:

  1. Write two paragraphs.
  2. Switch to source and back to wysiwyg.
  3. Without focusing editor, click 'body' in elements path.
  4. Only first paragraphs was selected.

Reproduced on FF, couldn't on Chrome, haven't checked the rest.

Change History (5)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Status: newconfirmed

comment:2 Changed 6 years ago by Frederico Caldeira Knabben

Introduced with git:a9d4df7.

comment:3 Changed 6 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: confirmedreview

It looks like the problem is that we're having two selection attempts happening at the same time when the editor gets focused. Firefox is buggy and is not able to handle this properly, making a random selection out of it.

I've proposed a fix on t/10119@cksource. It doesn't change much the logic of the code. It just demonstrates that the focus logic is very delicate and even the order of things matter. In any case, we're not able to do much about all this, until browsers will not be strong and stable about selection.

comment:4 Changed 6 years ago by Piotrek Koszuliński

Status: reviewreview_passed

OK, I haven't found any regressions and issue seems to be fixed. It's good to understand that this patch just targets more precisely patch for #9507.

PS. Is it possible to write test for this issue?

comment:5 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Fixed on master with git:a2136ce.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy