Opened 7 years ago

Closed 7 years ago

#10172 closed Bug (fixed)

Pressing DEL/Backspace in empty table cell moves cursor to next/previous cell

Reported by: Jakub Ś Owned by: Olek Nowodziński
Priority: Normal Milestone: CKEditor 4.1.1
Component: Core : Tables Version: 4.0
Keywords: Oracle Cc:

Description

In CKEditor 3.x and 4.0 beta it was possible to move to next cell using tab key only (Tab is also creating new rows).

From CKEditor 4.0 when you have empty table cell and press Delete or Backspace, cursor will jump to next or previous table cell.
This is happening in every browser.

Such behaviour, although doesn’t break anything, can be confusing for users thus Oracle guys are asking to remove it.

Change History (6)

comment:1 Changed 7 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.1.1

This one has been introduced with git:18c156a to fix #8916. I still agree that this behavior is undesired.

comment:3 Changed 7 years ago by Olek Nowodziński

Owner: set to Olek Nowodziński
Status: confirmedassigned

comment:4 Changed 7 years ago by Olek Nowodziński

Status: assignedreview

Made BSPACE/DEL behavior at the boundary of a table cell passive. Created branch t/10172 (+tests) that fixes the issue.

Unfortunately git:62a3b8bddf cannot be totally reverted, since it unifies the native BSPACE/DEL behavior on FF 3.6 that is undesired.

comment:5 Changed 7 years ago by Piotrek Koszuliński

Status: reviewreview_passed

R+, although:

  • I don't like that del/backspace leaves table. This is v3's behaviour, but I think that it may not be needed any more, since we have magicline. If someone agrees with me, let's have a ticket for this.
  • I found an issue in del behaviour, but it's older: #10289.

comment:6 Changed 7 years ago by Olek Nowodziński

Resolution: fixed
Status: review_passedclosed

Merged into master: git:1aa6e75329a6 (dev), a4c9835 (tests).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy