Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10300 closed Bug (invalid)

JS error when I click on a button in the toolbar before the editor has focus

Reported by: Jennifer Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0.2
Keywords: Cc:

Description

In IE8, if my browser is in Local Intranet Zone | Protected Mode on, I see a JS error if I click on a button in the toolbar without putting my focus in the editor first. This is the default Zone/Mode if I navigate to the site without a . in the URL. (Also I can see from the IE Developer tools that Browser Mode is IE8 Compat View and Document Mode is IE8 Standards.

Steps to reproduce:

  1. Open a brand new editor.
  2. Without putting focus in the editor click on any toolbar button. There is a JS error.

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; InfoPath.2) Timestamp: Thu, 28 Mar 2013 19:55:24 UTC

Message: Can't move focus to the control because it is invisible, not enabled, or of a type that does not accept the focus. Line: 241 Char: 519 Code: 0 URI: http://tfqatrunkfeatures/resources/6.5.0.102/ckeditor/ckeditor/ckeditor.js

Change History (2)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: newclosed

Like in #10292 - I tried to reproduce your issue, but everything works fine for me. I checked compatibility mode (which we of course support), I checked protected mode, everything and haven't encountered any issue.

Last edited 6 years ago by Jakub Ś (previous) (diff)

comment:2 Changed 6 years ago by Jakub Ś

Just a note:
Proper way to turn on compatibility view if using <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" /> on HTML page or TOP MENU->Tools->Compatibility View Settings.


About your JS error:
IE behaves very differently than other browsers when it comes to "focus" and "selection". That error message is very common. It happens when you call the focus() method on any element which is not visible at the page.
I think you may not telling us everything here - like that you have editor in hidden div or something like that.
To be able to help you, we need to reproduce the problem with a standard CKEditor installation. For that, you need to provide us a reduced test case for testing. Otherwise we'll hardly be able to provide you any useful information.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy