Opened 6 years ago

Closed 6 years ago

#10354 closed Bug (fixed)

Javascript error

Reported by: jwaldek Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

After save data from ckeditor and load it again a get this javascript error:

time: 2013-04-20 09:39:31 Error: TypeError: b is null Source file: http://somewebsite.pl/public/editor/ckeditor.js?t=C6HH5UF Row: 61

Tested on: Firefox Windows 7, CKEditor 4.1, utf-8

Maybe its' a problem with Polish language because i have some text i can't copy paste to cke editor (on official ckeditor demo website and on my website). I have problems with this text file: http://studiostron.eu/test.txt

I open it (editpad lite or other editor) and try paste and i got only one <br /> with no text

Attachments (1)

test.txt (1.1 KB) - added by jwaldek 6 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Status: newpending

A u mnie działa ;)

I opened the replacebycode sample, copied that text (from browser & from text editor) and pasted into editor. Everything works fine. I tested this on 4.0.2, 4.1 and latest master.

Could you describe exact steps that we need to do to reproduce this issue on fresh CKEditor? On which browser it happens, how do you copy (part of text or entire), where do you paste, etc. And is using editpad lite required or does this issue occur when copying from other text editors too?

comment:2 Changed 6 years ago by jwaldek

I have this problem in few editors (not only in EditPad lite) on latest Firefox and IE.

When i use CTRL+V i CKE Editor area i got:

<p><br /> &nbsp;</p>

Next i try CKE "Paste from Word" function + CTRL+V - works properly.

Next i use again CTRL+V in cke editor area - it works but when i refresh browser it fail again.

In online ckeditor demo i have this error after few tests:

Time: 2013-04-20 13:42:48 Error: TypeError: C.getLast(...) is null Source file: http://ckeditor.com/apps/ckeditor/4.1/ckeditor.js?mlc5o1 Row: 301

comment:3 Changed 6 years ago by Jakub Ś

I have tried your example in default editor in replacebycode and ajax sample (which imitates submit with destroying and creating editor but without real submit and server-side overhead). No error occurred there - I have tried opening File with Notepad and Notepad++ in latest Firefox and IE.

Please note that is you use Polish language this may be encoding issue. You should be using utf-8 everywhere - DB, application and HTML page in order to avoid weird characters in final output. Since demo version is using utf-8 and you are able to reproduce it there (contrary to us) then perhaps problem is with your machine?

  1. Could you try reproducing this issue on different machine (best with normal editor like notePad++)?
  2. Could you provide exact steps (step by step scenario) to reproduce this? Perhaps there is something wrong we both have done in our TC steps.

comment:4 Changed 6 years ago by jwaldek

I made few test

three machines (2x windows 7 64bit, one windows xp , all polish versions)

  1. editors: notepad ++, windows notepad, editpad lite
  1. test procedure:
  • open text file in editor
  • function "select all"
  • CTRL+C
  • open ckeditor offical demo
  • put cursor in editor area
  • CTRL+V
  1. test result - all browsers polish versions:
  • firefox, IE, Opera - fail (only works CTRL+ V in Copy from Word or if i copy small part of problematic text)
  • google chrome - works ok

comment:5 Changed 6 years ago by Jakub Ś

You might say we are testing in same environments.

Tc is straight forward, open text file, select text with function on Ctrl+A, Ctrl+c, open demo and paste with ctrl+v into empty or containing elements editor (inline, divbased or iframed). Error should occur yet I wasn't able to get it in any browser.

I will ask others to check this.

comment:6 Changed 6 years ago by Piotrek Koszuliński

One more thing - could you attach that text file here? We'd better avoid downloading it from the server, what can change some things...

Changed 6 years ago by jwaldek

Attachment: test.txt added

comment:7 Changed 6 years ago by jwaldek

After update Ckeditor to 4.1.1 problem fixed

comment:8 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: pendingclosed

Cool :) This is a good news. I also confirm that I can reproduce this after downloading test.txt file.

This issue was fixed by git:48197249 which is a part of #10260.

Thanks for your effort.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy