Opened 6 years ago

Closed 3 years ago

#10465 closed Bug (invalid)

JAWS reading width field & width unit dropdown & it's values when Cell Properties dialog opened

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: Accessibility Version: 3.2
Keywords: IBM Cc: Damian, Teresa Monahan, Irina

Description

To reproduce the defect:

  1. with JAWS On,Open any CK Editor sample & insert a table.
  1. Open Cell Properties dialog, by clicking on Cell Properties option in Cell sub menu

Expected Result: JAWS reads Cell Properties dialog title & then the Width field which has focus.

Actual Result: JAWS reading Cell Properties dialog title, then it reads width & then it reads width unit & it reads pixels & percent(width unit options)

This is because width input field has aria-labelled by with cke_228_label cke_232_uiElement. The cke_232_uiElement label points to the div that holds width unit dropdown. This should be removed

Change History (3)

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed
Version: 3.2

Problem can be reproduced from CKEditor 3.2 in both CKE 3.x and 4.x.

comment:2 Changed 3 years ago by Anna Tomanek

Summary: JAWS reading width field & width unit dropdown & it's values when Cell Properties dialog openedJAWS reading wrong labels in the Cell Properties dialog

comment:3 Changed 3 years ago by Marek Lewandowski

Resolution: invalid
Status: confirmedclosed
Summary: JAWS reading wrong labels in the Cell Properties dialogJAWS reading width field & width unit dropdown & it's values when Cell Properties dialog opened

At first it looked like a bug, however it is on purpose. The reason for it is to also include a proper value unit.

Probably at a time of writing this issue JAWS might had have a poor support for select elements in label, which caused it to read the way that it was described in the ticket description. However today it properly reads only the current value which is desried.

Interestingly during checking this ticket I've found issue #14254 which is related to wrong label for height field.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy