Opened 6 years ago

Closed 6 years ago

#10484 closed Bug (duplicate)

[IE] Source dialog fires beforeunload event

Reported by: Karen Ananiev Owned by:
Priority: Normal Milestone:
Component: General Version: 4.1
Keywords: IE9 IE10 Cc:

Description

  1. Attach the "onbeforeunload" event to the page (I used repleacebyclass.html from samples folder):
<script>
	window.attachEvent('onbeforeunload', function() {
		return 'You will lose your content.';
	});
</script>
  1. Add "sourcedialog" plugin.
  1. Open editor, open source dialog and click OK. The confirm dialog will appear.

Change History (1)

comment:1 Changed 6 years ago by Jakub Ś

Keywords: IE9 IE10 added
Resolution: duplicate
Status: newclosed
Version: 4.1.14.1

This issue is a duplicate of #9958.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy