Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#10485 closed Bug (fixed)

IE: Error thrown when we try to paste simple text from word doc

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version: 4.1
Keywords: IBM Cc: Teresa Monahan, Irina

Description

To reproduce the defect:

Make the following changes to config

Config.pasteFromWordRemoveFontStyles = false;

config.pasteFromWordRemoveStyles = false;

Copy simple text from word or use the data from attached word doc.

Paste it in editor.

Issue: We are getting an dialog with an error message saying It was not possible to clean up the pasted data due to an internal error

Attachments (1)

sample test doc.doc (23.5 KB) - added by Satya Minnekanti 7 years ago.

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by Satya Minnekanti

Attachment: sample test doc.doc added

comment:1 Changed 7 years ago by Jakub Ś

Status: newpending

I have tried this TC in every browser but didn't get it.

We have some issues like #6985, #8780, #8516 (I will need to look into this one once more) but all of them concern lists or tables and not plain text.

  1. Please provide exact steps to reproduce this problem?
  2. Should editor be initially empty or can be emptied?
  3. How should I paste content - ctrl+V, dialog or it doesn't matter?
  4. Just to make sure. Are we talking about CKE 4.1 order or newer version?

comment:2 in reply to:  1 Changed 7 years ago by Satya Minnekanti

Replying to j.swiderski:

I have tried this TC in every browser but didn't get it.

We have some issues like #6985, #8780, #8516 (I will need to look into this one once more) but all of them concern lists or tables and not plain text.

  1. Please provide exact steps to reproduce this problem?
  2. Should editor be initially empty or can be emptied?
  3. How should I paste content - ctrl+V, dialog or it doesn't matter?
  4. Just to make sure. Are we talking about CKE 4.1 order or newer version?

@j.swiderski Have u applied the config changes that i have mentioned in the steps to reproduce before trying to reproduce the defect. All of us can reproduce this issue on ck source build when we apply the config changes. All we were doing is just copy & paste the data directly in to editor.

comment:3 Changed 7 years ago by Satya Minnekanti

Summary: Error thrown when we try to paste simple text from word docIE: Error thrown when we try to paste simple text from word doc

We could still reproduce the error in IE8 & IE9,when we applied config changes as mentioned in the steps to reproduce

comment:4 Changed 7 years ago by Teresa Monahan

@j.swiderski - have you been able to reproduce this in IE? If so, can this please be considered for 4.1.2 since it is a basic usecase? Thanks

comment:5 Changed 7 years ago by Jakub Ś

Resolution: fixed
Status: pendingclosed

We have checked this issue once more. You are right the problem can be reproduced in version 4.1 but not in 4.1.1 and latest git. It seems to be fixed.
My colleague thinks this problem might have been fixed with this ticket #10285.

I'm closing this issue as fixed but please check it in latest CKEditor and leave reply if you are still able to reproduce.

comment:6 Changed 6 years ago by Frederico Caldeira Knabben

Component: GeneralPlugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy