Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10514 closed Bug (invalid)

CKEditor cause ambiguous page scroll

Reported by: Marko Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.5
Keywords: Cc:

Description

Hi everyone. I know there was topic like this but I couldn't find an open ticket, that's why I create this ticket. I found this bug in 3.6.5 version. I have two CKeditors on page, and when I press enter it scrolls page down, alomost to the bottom. Those two CKeditors are in two fields in two separated rows of table. I tried patches from older topic about this problem, but without results. Can anyone help me with this?

P.S. I tried newest verson but the bug remains.

Attachments (4)

pagescrollingCKEDITOR.php (8.4 KB) - added by Marko 6 years ago.
pagescrollingCKEDITOR.html (8.4 KB) - added by Marko 6 years ago.
generatedCK.html (324.3 KB) - added by Marko 6 years ago.
functionCK.html (261.7 KB) - added by Marko 6 years ago.

Download all attachments as: .zip

Change History (31)

comment:1 Changed 6 years ago by Jakub Ś

Could you please provide reduced code of your HTML page?

comment:2 in reply to:  1 Changed 6 years ago by Marko

Replying to j.swiderski:

Could you please provide reduced code of your HTML page?

It's a bit of a problem cause my HTML code has about 1000 rows... One more thing, I noticed that this is happening because the table where are this two CKEditors is resizable. When I say resizable I mean that I load data in my table from database and the table don't have fixed size. Why is that a problem?

Last edited 6 years ago by Marko (previous) (diff)

comment:3 Changed 6 years ago by Marko

Also I forgot to mention that this bug start after update web browsers. (Firefox 21,Chrome 27.0.1453.110,Chromium 25.0.1364.160).

comment:4 Changed 6 years ago by Piotrek Koszuliński

@vaske1986 Which tickets and topics do you mean?

And first thing you should do is upgrading CKEditor to latest version. Old patches may not work if not applied without their requirements and since there are closed tickets for similar problem perhaps it is already fixed.

comment:5 Changed 6 years ago by Piotrek Koszuliński

Status: newpending

comment:6 Changed 6 years ago by Marko

Ticket #4397, topic http://ckeditor.com/forums/CKEditor-3.x/CKEditor-cause-ambiguous-page-scroll I'll try to install latest version and then post what happen here.

comment:7 Changed 6 years ago by Marko

Tried newest version and the problem remain. Any other solution?

comment:8 Changed 6 years ago by Marko

Is there a chance that CKeditor get wrong parent element? Because I got table in table and then in that other table I have two CKEditors.

comment:9 Changed 6 years ago by Marko

I also try to iframe CKeditor on page but the problem still remain.

comment:10 Changed 6 years ago by Marko

Just to add that I moved ckeditors at the top of the table, so there are no resizable elements above, and it work. This is temporary solution, I hope that someone will find better solution.

comment:11 Changed 6 years ago by Jakub Ś

Could you please provide reduced code of your HTML page?

It's a bit of a problem because my HTML code has about 1000 rows...

Like I have written in first comment - Reduced. You don't need to send me 100 rows page. In fact I don't want to work with something like that. Instead please try to prepare as little file as possible that show the problem. I'm just interested in code that is causing this problem and no overhead.

Please tell me which version of editor do you use now after upgrade - is it 4.1.1?

Please tell me in which browsers you get this issue.

One last thing - what are exact steps to reproduce this issue. When you press enter do any of editors have focus or you simply open page and press enter?

Please reply to all my questions and provide reduced file.

comment:12 in reply to:  11 Changed 6 years ago by Marko

Replying to j.swiderski:

Could you please provide reduced code of your HTML page?

It's a bit of a problem because my HTML code has about 1000 rows...

Like I have written in first comment - Reduced. You don't need to send me 100 rows page. In fact I don't want to work with something like that. Instead please try to prepare as little file as possible that show the problem. I'm just interested in code that is causing this problem and no overhead.

Please tell me which version of editor do you use now after upgrade - is it 4.1.1?

Please tell me in which browsers you get this issue.

One last thing - what are exact steps to reproduce this issue. When you press enter do any of editors have focus or you simply open page and press enter?

Please reply to all my questions and provide reduced file.

I attach file. This problem occur in Firefox, Chrome, Chroimum and Rekonq(I use Ubuntu 12.10 - KDE). Sorry cause file is big, but I left it almost like it is, because you need to see where I have problem.

comment:13 Changed 6 years ago by Piotrek Koszuliński

Could you attach a reduced HTML file? We're not able to run this PHP code and this sample is too long.

comment:14 in reply to:  13 Changed 6 years ago by Marko

Replying to Reinmar:

Could you attach a reduced HTML file? We're not able to run this PHP code and this sample is too long.

Sorry for that, I attached reduced version now.

Changed 6 years ago by Marko

Attachment: pagescrollingCKEDITOR.php added

Changed 6 years ago by Marko

Attachment: pagescrollingCKEDITOR.html added

comment:15 Changed 6 years ago by Marko

I attached html file now, so you can run it.

comment:16 Changed 6 years ago by Marko

My problem is the sam as it was in ticket #9136

comment:17 Changed 6 years ago by Marko

I tried 4.1.2 version and the bug is still there...I'm sure there is some problem with specific page code, cause I use ckeditor on other pages and it works perfectly. Does anyone know what can confuse ckeditor? When I say confuse I mean about page scrolling...

comment:18 Changed 6 years ago by Marko

On Firefox 20 and earlier, this problem didn't exist.

comment:19 Changed 6 years ago by Jakub Ś

I have checked your page in Chrome, Chromium, Firefox on Ubuntu, next I have checked Windows browsers and didn't get any scrolling.

Are you able to reproduce this problem with HTML sample you have provided? @vaske1986 when we asked users for test case file in issue we can't reproduce we expect to get reduced and working file e.g. something that can be put in samples folder of default editor and will show the problem.

I have checked #9136. Problem mentioned there no longer occurs in CKEditor 4.1.2 so I have closed it as fixed.

If this issue can be really reproduced then please provide working test-case file otherwise I will have to close this issue.

One more thing - please note that we check things in default editor - perhaps you have done some core code modifications or have custom plugins that are causing this problem. Please check your test case file in default editor so that you could exclude this possibility.

comment:20 in reply to:  19 Changed 6 years ago by Marko

Replying to j.swiderski:

I have checked your page in Chrome, Chromium, Firefox on Ubuntu, next I have checked Windows browsers and didn't get any scrolling.

Are you able to reproduce this problem with HTML sample you have provided? @vaske1986 when we asked users for test case file in issue we can't reproduce we expect to get reduced and working file e.g. something that can be put in samples folder of default editor and will show the problem.

I have checked #9136. Problem mentioned there no longer occurs in CKEditor 4.1.2 so I have closed it as fixed.

If this issue can be really reproduced then please provide working test-case file otherwise I will have to close this issue.

One more thing - please note that we check things in default editor - perhaps you have done some core code modifications or have custom plugins that are causing this problem. Please check your test case file in default editor so that you could exclude this possibility.

That's the problem. When I try with html only it works fine, but when I insert the php code,there is a problem.

comment:21 Changed 6 years ago by Marko

Same thing with 4.1.2. Do you have any idea what can cause this problem?

comment:22 Changed 6 years ago by Jakub Ś

Then why are you sending us something that works :).

Since there is no PHP in generated page (in browser) could you perhaps send us generated HTML file - the one that you get after editor is fully loaded.

Perhaps you could grant us test access to your application so that we could know if this is editor or your application issue? My email is j.swiderski@…

comment:23 in reply to:  22 Changed 6 years ago by Marko

Replying to j.swiderski:

Then why are you sending us something that works :).

Since there is no PHP in generated page (in browser) could you perhaps send us generated HTML file - the one that you get after editor is fully loaded.

Perhaps you could grant us test access to your application so that we could know if this is editor or your application issue? My email is j.swiderski@…

I sent the page, and then tested. I'm sorry, my mistake.:) I have generated html, but I'll send it tomorrow, cause I need to remove some data. I'm affraid it's impossible to grant test access. Higher authority decision, not mine. But error also occur on generated html. I'll attach html till tomorrow morning, so you can see. Thanks for help!

Last edited 6 years ago by Marko (previous) (diff)

Changed 6 years ago by Marko

Attachment: generatedCK.html added

Changed 6 years ago by Marko

Attachment: functionCK.html added

comment:24 Changed 6 years ago by Marko

I attach two HTML files. In generatedCK you have generated HTML that I get when I load page. In functionCK I send HTML with javascript function (CKEDITOR.replace). Second CKEditor is making a problem.

comment:25 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

I think A word of criticism is required here. I'm sorry.

@vaske1986 why in the world haven't you used doctype nor HTML?
Wrap your page in below and it will work (in CKE 4.1.2)

<!DOCTYPE html>
<html>
...
</html>

I'm closing this ticket as invalid.

comment:26 Changed 6 years ago by Marko

Thank you so so so much. I paste the wrong code, so I have html tag but when I add <!DOCTYPE html> it works perfectly (ckeditor 3.6.5). Thank you for milion times! :D

Last edited 6 years ago by Marko (previous) (diff)

comment:27 Changed 6 years ago by Jakub Ś

Just one note. If you are using CKEditor 3.x please rather use one of HTML4 doctypes as CKEditor 3.x was designed to work with HTML4. Of course may HTML5 features work with it too but if you are looking for modern editor with almost full HTML5 support please useCKEditor 4.x.

Sample HTML4 doctype declaration:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy