Opened 5 years ago

Last modified 5 years ago

#10549 confirmed Bug

Chrome: format lost when cut & paste subscript/superscript text

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Webkit IBM Cc: Teresa Monahan, Irina

Description

To reproduce the defect:

  1. Open any CKSample,clear existing text
  1. Type some text, select it & apply Subscript/Superscript format
  1. See that sub/super tag applied to the text.
  1. Select all the text by using Ctrl + A & press CTRL + X to cut the text
  1. Press CTRL+ V to paste the text.

Expected Result: Pasted text has subscript/superscript format applied & sub/super tag shown in HTML source

Actual Result: Pasted text has no subscript/superscript format applied

Change History (5)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Status: newpending

I cannot reproduce this. Tested on http://ckeditor.com/demo on Chrome Version 28.0.1500.52.

Could you test it again on Chrome's version >= mine? Perhaps it was some Chrome's regression.

comment:2 in reply to:  1 Changed 5 years ago by Satya Minnekanti

Replying to Reinmar:

I cannot reproduce this. Tested on http://ckeditor.com/demo on Chrome Version 28.0.1500.52.

Could you test it again on Chrome's version >= mine? Perhaps it was some Chrome's regression.

@J.swiderski My version of Chrome is 27 & i can't see a official release of chrome 28. only dev version. Are u using a released version?

comment:3 Changed 5 years ago by Piotrek Koszuliński

Not j.swiderski this time :D

I'm using stable version which is available for Ubuntu (automatically updated). Perhaps it will be available for Mac/Win a little bit later. Maybe let's wait few days before checking again. Perhaps Chrome's versions are not propagated equally for every OS.

comment:4 Changed 5 years ago by Jakub Ś

I can confirm this issue in Chrome 27 and Safari 6.0.5 from CKEditor 3.0 (Safari 5 has still this div wrapping result).

Perhaps this is some quirks in Chrome 27 and will be fixed in Chrome 28 but as it was reproducible in Safari 6.0.2 it is still reproducible in latest Safari 6.0.5.

I'm confirming this issue for Webkit.

Last edited 5 years ago by Jakub Ś (previous) (diff)

comment:5 Changed 5 years ago by Jakub Ś

Keywords: Webkit added
Status: pendingconfirmed
Version: 3.0
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy