Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#10613 closed Bug (wontfix)

The expected native right click context isn't available over entire CKEditor area

Reported by: Jared Cobb Owned by:
Priority: Normal Milestone:
Component: General Version: 4.1.2
Keywords: Cc:

Description

I have disabled the CKEditor right click context menu (in favor of the native browser's right click context menu) by removing the proper plugins in the config like so:

CKEDITOR.config.removePlugins='liststyle,tabletools,scayt,menubutton,contextmenu';

However I noticed that in order to "Paste" (for example) you need to right click exactly on the flashing cursor. If you right click anywhere else in the content area, the browser behaves as if you're not focused on a content area, and the "Paste" option is not available.

I would expect that you should be able to right click anywhere the content area and be able to choose "Paste".

I provided a simple JSFiddle (because I needed a version that has the CKEditor right click context disabled).

http://jsfiddle.net/RcatT/

To reproduce, right click on the cursor and see that you can paste text. Now right click somewhere lower, and see that paste is missing and the context menu is different.

Change History (2)

comment:1 Changed 6 years ago by Jakub Ś

Resolution: wontfix
Status: newclosed

Editor is mainly focused on handling own context menu and not browsers native one.

This is happening because body has default height auto and when you clean editor contents height is simply one line. This is why this is happening.

The only thing you can do here is modify contents.css file: remove margins and paddings for body as well as adding minimum height e.g. min-height:200px.

comment:2 Changed 5 years ago by Jakub Ś

Other tickets that concern same source of the problem: #11792, #10792, #11280, #10169.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy