Opened 6 years ago

Closed 6 years ago

#10614 closed Bug (duplicate)

IE11: Selection is lost when opening dropdowns or menu buttons or inserting tables

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0 Beta
Keywords: IE11 Cc:

Description (last modified by Jakub Ś)

  1. Select some text
  2. Open dropdown or one of Color Menu Button (visible selection is gone)
  3. Select any style or color from dropdown or menu buttons

Result: Selection is lost and cursor is blinking at the beginning of the content ^Apollo 11

This is happening in iframed editor only - inline and divarea work fine.

UPDATES:

  • Same happens when you try to insert table (or table inside table) - it gets inserted at the top of document.
  • Same happens when you try to remove table with CKEditor context menu option.
  • Even worse happens when you try to insert new column - selection is lost and JS error is thrown because of that.
  • Same happens when you try to insert place holder. When you try to insert second placeholder in a row you get JS error "Unable to get property 'scrollIntoView' of undefined or null reference".
  • When inserting a link i BBCODE I have got: Unable to get property 'collapsed' of undefined or null reference

Change History (7)

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed
Version: 4.0 Beta

comment:2 Changed 6 years ago by Jakub Ś

Description: modified (diff)
Summary: IE11: Selection is lost when opening dropdowns or menu buttonsIE11: Selection is lost when opening dropdowns or menu buttons or inserting tables

comment:3 Changed 6 years ago by Jakub Ś

Description: modified (diff)

comment:4 Changed 6 years ago by Jakub Ś

Description: modified (diff)

comment:5 Changed 6 years ago by Jakub Ś

Description: modified (diff)

comment:6 Changed 6 years ago by Jakub Ś

Description: modified (diff)

comment:7 Changed 6 years ago by Piotrek Koszuliński

Resolution: duplicate
Status: confirmedclosed

I'm closing this as a DUP of #10612, because it's fixed by initial t/10612b's commit and I want to clean up a little bit.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy