Opened 6 years ago

Last modified 6 years ago

#10636 confirmed Bug

Error thrown when in/outdenting inside of a list element (caret in a paragraph)

Reported by: Olek Nowodziński Owned by:
Priority: Normal Milestone:
Component: Core : Lists Version: 3.6.3
Keywords: Cc:

Description

<ol>
        <li>x
            <p>y^</p>

            <ol>
                <li>z</li>
            </ol>
	</li>
</ol>
  • When outdenting:
    Uncaught TypeError: Cannot call method 'getParent' of null 
    
  • When indenting: Nothing happens, in previous version margin-left added to the outer list.

Change History (4)

comment:1 Changed 6 years ago by Olek Nowodziński

Milestone: CKEditor 4.2CKEditor 4.2.1

comment:2 Changed 6 years ago by Jakub Ś

Milestone: CKEditor 4.2.1
Resolution: duplicate
Status: newclosed

DUP of #9151.

@a.nowodzinski I have moved milestone to #9151

comment:3 Changed 6 years ago by Wiktor Walc

Resolution: duplicate
Status: closedreopened

I'm reopening it because a.nowodzinski confirmed that the issue is valid.

comment:4 Changed 6 years ago by Jakub Ś

Status: reopenedconfirmed
Version: 4.23.6.3
  1. "When indenting: Nothing happens" - this can be reproduced from CKEditor 3.0
  2. "When outdenting: " Error is thrown:
    Message: TypeError: node is null
    Code: return selected.$;
    Line: 1329
    Code: selection.js
    This part can be reproduced from CKEditor 3.6.3 rev. [7419]
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy