Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#9151 closed Bug (fixed)

Outdent RLT list item results in item wrapped in Div or P

Reported by: Jakub Ś Owned by: Olek Nowodziński
Priority: Normal Milestone:
Component: Core : Lists Version: 3.6.3
Keywords: Cc:

Description (last modified by Jakub Ś)

I have found this problem while reproducing #9123

  1. Load the following editor content:
          <ol>
          	<li>
          		foo
          		<ol>
          			<li dir="rtl">
          				^bar</li>
          			<li>
          				baz</li>
          		</ol>
          	</li>
          </ol>
    
  2. Press the Outdent (Decrease Indent) button:

Result: Please note that there is P wrapping "bar" element. In DIV and BR mode this is changed to DIV.

<ol>
	<li>
		foo</li>
	<li dir="rtl">
		<p dir="rtl">
			^bar</p>
		<ol>
			<li>
				baz</li>
		</ol>
	</li>
</ol>

Reproducible in IE6-9 and Firefox from CKEditor 3.6.3 rev. [7419].

Change History (9)

comment:1 Changed 7 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 7 years ago by Wiktor Walc

Component: GeneralCore : Lists

comment:3 Changed 6 years ago by Jakub Ś

#10564 is also caused by [7419]

comment:4 Changed 6 years ago by Jakub Ś

Description: modified (diff)

comment:5 Changed 6 years ago by Jakub Ś

Milestone: CKEditor 4.2.1

#10636 was marked as duplicate.

comment:6 Changed 6 years ago by Olek Nowodziński

Owner: set to Olek Nowodziński
Status: confirmedassigned

comment:7 Changed 6 years ago by Olek Nowodziński

Starting with the following HTML:

<ol>
	<li>X
	<ol>
		<li dir="rtl">^Y</li>
		<li>Y</li>
	</ol>
	</li>
	<li>X</li>
</ol>

and executing outdent produces:

<ol>
	<li>X</li>
	<li dir="rtl">Y
	<ol>
		<li>Y</li>
	</ol>
	</li>
	<li>X</li>
</ol>

Which isn't perfect and kinda controversial as the second item of the initially nested list (and its successors, if any) also gets dir="rtl". Still I see no paragraphs or divs there and I'm unable to reproduce the case.

comment:8 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: assignedclosed

Problem has expired on trunk -> It got fixed in version 3.6.4.

comment:9 Changed 6 years ago by Wiktor Walc

Milestone: CKEditor 4.2.1

The ticket was fixed in 3.6.4 and if it cannot be reproduced in 4.x then the milestone 4.2.1 does not make sense here.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy