Opened 6 years ago

Closed 6 years ago

#10690 closed Bug (wontfix)

CKEditor within xulrunner

Reported by: msuhr Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.6
Keywords: Cc:

Description

I cannot integrate ckeditor in a HTML based xulrunner app. I got an exception (NS_ERROR_FAILURE) if the ckeditor.js try to call 'document.domain'.

This is maybe a FF Bug (see https://bugzilla.mozilla.org/show_bug.cgi?id=417021).

Is there any possibility to integrate ckeditor in a xulrunner app?

Greets

Change History (3)

comment:1 Changed 6 years ago by msuhr

I've use a workaround for this error but the editor still not works. Now I get a SecurityError if the editor content should be set (core/dom/document.js Line: 243).

Is it possible to create an xul app which integrated CKEditor to run as standalone app (without creating an own plugin)? I think with own plugin I can override the write method do use data URI (data:text/html;charset=utf-8,<h1>test</h1>) isntead of the document.write.

Greets

Last edited 6 years ago by msuhr (previous) (diff)

comment:2 Changed 6 years ago by msuhr

In Ticket #5689 there was fixed a bug for restricted access to document.domain. But this works not for standalone apps.

comment:3 Changed 6 years ago by Jakub Ś

Keywords: xul xulrunner firefox removed
Resolution: wontfix
Status: newclosed

We haven't tried using CKEditor with XULRunner so officially there is no support for it.

It is quite possible that there are some conflicts between these two but like I said we have no experience in using XULrunner with CKEditor and we provide no support for it.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy