Opened 7 years ago

Closed 7 years ago

#5689 closed Bug (fixed)

Adjustments for WriteArea

Reported by: Alfonso Martínez de Lizarrondo Owned by: Alfonso Martínez de Lizarrondo
Priority: Normal Milestone: CKEditor 3.4
Component: General Version:
Keywords: Cc:

Description

In order to port WriteArea to use CKEditor some minor adjustments are needed.

The first one might also help in other environments if access to document.domain is restricted, the second one should affect only code running in the Firefox chrome.

Attachments (1)

5689.patch (1.3 KB) - added by Alfonso Martínez de Lizarrondo 7 years ago.
Proposed patch

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by Alfonso Martínez de Lizarrondo

Attachment: 5689.patch added

Proposed patch

comment:1 Changed 7 years ago by Garry Yao

Keywords: Review- added; Review? removed
Resolution: invalid
Status: newclosed

We'd use adapter instead of modifying core codes for non-browser compatibility, e.g. Mozilla application, Adobe AIR, ActiveX Objects.

comment:2 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: Confirmed Review? added; Review- removed
Resolution: invalid
Status: closedreopened

I understand the reason behind Garry's comments, but in this case the changes are so minimal that we could take it in consideration. We must just be sure the changes on isCustomDomain will not break anything.

comment:3 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: Confirmed removed
Status: reopenedconfirmed

comment:4 Changed 7 years ago by Wiktor Walc

Keywords: Review? removed
Owner: changed from Alfonso Martínez de Lizarrondo to Wiktor Walc
Status: confirmedreview

comment:5 Changed 7 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

Please be sure to add proper comments on L326 and L343 and fix the coding style issues on L327 and L344 before commiting.

comment:6 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Resolution: fixed
Status: review_passedclosed

Fixed with [5752]

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy