Opened 12 years ago

Closed 12 years ago

#1079 closed Bug (duplicate)

fckEditor inside UpdatePanel broken in VS2008 beta2

Reported by: Nima Dilmaghani Owned by:
Priority: Normal Milestone:
Component: Server : ASP.Net Version: FCKeditor 2.4.3
Keywords: Cc:

Description

When placing an fckEditor inside an UpdatePanel, upon submitting to the server, the content of the fckEditor gets cleared. This has been a known issue prior to Vs2008 Beta2. The solution is documented here: http://jlcoady.net/archive/2007/03/30/f ... pdatepanel here: http://wiki.fckeditor.net/Troubleshooti ... 0a41253d76 and here in the forums:

http://forums.asp.net/p/1028530/1513800.aspx#1513800

So using VS2008 Beta1, I used

function FCKUpdateLinkedField(id) { try { if(typeof(FCKeditorAPI) == "object") { FCKeditorAPI.GetInstance(id).UpdateLinkedField(); } } catch(err) { } } and everything worked fine.

I upgraded to VS2008 Beta2, here Microsoft Ajax Library is included in the framework.

Now I get an exception thrown every time I try to submit my form. The xmlHttpRequest has a status code of 500 with a status text of "Interenal Server Error"

Can you please check into this and see if the problem is on Microsoft's side, connect with them to fix it so .NET3.5 would not break fckEitor going forward.

Thanks

Change History (1)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: .net3.5 atlas updatepanel internal server error removed
Milestone: FCKeditor.Net 2.3
Resolution: duplicate
Status: newclosed

DUP of #234

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy