Opened 6 years ago

Closed 5 years ago

#10843 closed Bug (fixed)

MathJax widget tests

Reported by: Piotr Jasiun Owned by: Piotr Jasiun
Priority: Normal Milestone: CKEditor 4.3
Component: General Version: 4.3 Beta
Keywords: Cc:

Description (last modified by Piotr Jasiun)

Add missing tests to MathJax plugin:

  • tests for: inline editor
  • tests for: undo/redo
  • tests for: absolute path and preview plugin
  • tests for: if ( el.children.length > 1 || el.children[ 0 ].type != CKEDITOR.NODE_TEXT )

Change History (17)

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 5 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: confirmedassigned

comment:3 Changed 5 years ago by Piotr Jasiun

As a part of this ticket I will also work on:

  • tests which fails on IE,
  • test performance.

comment:4 Changed 5 years ago by Piotr Jasiun

Description: modified (diff)
Summary: MathJax widget - missing testsMathJax widget tests

comment:5 Changed 5 years ago by Piotr Jasiun

Status: assignedreview

Most of the tests were rewritten. Now part of them works on frame wrapper mock, without real mathJax lib what is much faster. I ran these tests in all browser on dev and release but this should be done again during review (especially in IE). Everything in t/10937 branch.

comment:6 Changed 5 years ago by Piotr Jasiun

Status: reviewassigned

comment:7 Changed 5 years ago by Piotr Jasiun

Resolution: fixed
Status: assignedclosed

comment:8 Changed 5 years ago by Piotr Jasiun

Resolution: fixed
Status: closedreopened

Reopen ticked because of IE9 problems.

comment:9 Changed 5 years ago by Piotr Jasiun

Status: reopenedreview

Changes in t/10843b and t/10843b tests.

comment:10 Changed 5 years ago by Frederico Caldeira Knabben

Status: reviewreview_failed

We understood that there may be better ways to solve this problem. Basically, the "mathJaxUpdateDone" event should be fired by the iframes, which are very unstable, but go a standard CKEditor object, which can be either "editor" or CKEDITOR.

comment:11 Changed 5 years ago by Piotr Jasiun

Status: review_failedreview

Changes done... and pushed now.

comment:12 Changed 5 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:13 Changed 5 years ago by Piotr Jasiun

Resolution: fixed
Status: review_passedclosed

Closed:

I also added some jsDuck tags to mathjax plugin to mark some properties as local.

comment:14 Changed 5 years ago by Piotr Jasiun

Resolution: fixed
Status: closedreopened

I found that FF also behave differently with and without cache so these tests need some more improvements.

comment:15 Changed 5 years ago by Piotr Jasiun

Status: reopenedreview

Changes in t/10843c test branch. Now tests works on FF without cache.

I also ignored test for loading indicator on IE8, bacause IE8 sometimes load everything synchronously, without indicator.

comment:16 Changed 5 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:17 Changed 5 years ago by Piotr Jasiun

Resolution: fixed
Status: review_passedclosed

tests:f11e069

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy