Opened 6 years ago

Closed 5 years ago

#10863 closed Bug (fixed)

Change to which enterMode filter#applyTo defaults

Reported by: Piotrek Koszuliński Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.3
Component: General Version: 4.3 Beta
Keywords: Cc:

Description

Currently it defaults to activeEnterMode, but as we changed defaults in htmlDP to the main enterMode and filter, we should also change here.

Change History (9)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Status: newconfirmed
Version: 4.2.2 (GitHub - master)4.3 (GitHub - major)

comment:2 Changed 5 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:3 Changed 5 years ago by Piotrek Koszuliński

Status: assignedreview

Pushed t/10863 on dev and tests.

comment:4 Changed 5 years ago by Olek Nowodziński

Rebased branches on major.

comment:5 Changed 5 years ago by Frederico Caldeira Knabben

Status: reviewpending

The proposed changes alone with the new tests are not enough to understand the reasoning behind this change. Can this be translated into a real world TC?

comment:6 Changed 5 years ago by Piotrek Koszuliński

Status: pendingreview

It's the same reason as on final #9764 review. Do you remember that you asked me to change the enter mode and filter to which editor#setData & editor#getData default? I forgot to change the enter mode here, so it's just a cleanup to avoid confusion in the future

It'd be hard to find a real TC though, because most of the time filter#applyTo is used by htmlDataProcessor, which also chooses the enter mode (and it defaults to editor.enterMode, not activeEnterMode) and passes it to filter#applyTo. However, it may happen that someone will use filter#applyTo directly. Then this change may be important.

comment:7 Changed 5 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

Ok... passing it, but it is still an unclear change for me.

comment:8 in reply to:  7 Changed 5 years ago by Frederico Caldeira Knabben

Replying to fredck:

Ok... passing it, but it is still an unclear change for me.

By "unclear", I don't mean "wrong".

comment:9 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Merged to major with git:e235ac9 on dev and 8be42bf on tests.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy