Opened 6 years ago

Closed 6 years ago

#10917 closed Bug (duplicate)

Unnecessary   in WebKit browsers

Reported by: joshmaker Owned by:
Priority: Normal Milestone:
Component: Core : Editable Version: 4.0
Keywords: WebKit Blink Cc:

Description

I have observed both Chrome and Safari adding unnecessary " " characters when a normal space would work better.

This issue is easy to replicate. Start with some simple HTML such as

<p>This is a simple sentence.</p>

Now delete and re-create all the spaces in the sentence one by one. In FireFox, the markup will look exactly the same before and after doing this. However, in both Safari and Chrome, after I delete and re-create the spaces the markup looks like this:

<p>This&nbsp;is&nbsp;a&nbsp;simple&nbsp;sentence.</p>

I have been able to consistently replicate this bug in both Chrome 29.0.1547.76 for Mac, and Safari 6.0.5

This bug occurs in CKEditor 4.2, 4.3, and in the latest nightly.

Attachments (1)

non-breaking-space-bug.gif (221.1 KB) - added by joshmaker 6 years ago.
GIF animation of the bug

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by joshmaker

Attachment: non-breaking-space-bug.gif added

GIF animation of the bug

comment:1 Changed 6 years ago by Jakub Ś

Keywords: Blink added; &nbsp removed
Status: newconfirmed
Version: 4.0

Problem can be reproduced from CKEditor 4.0 (works fine in 3.6.x nad 4.0 beta) in Blink and Webkit.

comment:2 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

This is in fact DUP of #9929.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy