Opened 6 years ago

Closed 5 years ago

#10934 closed Bug (fixed)

Blur not fired correctly in Chrome or Safari

Reported by: nik Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

The blur event does not correctly fire in Chrome or Safari. On first focus and blur it works, but then subsequently fails to fire if the content does not change in the editor. If there is content in the editor and no text is selected, but the editor is given focus and the backspace key is used to delete characters, and then the editor is blurred, again the blur event does not fire (unless all of the content has been deleted).

Attached is a very simple example that should display an alert on blur. If you try entering the editor, and then leaving the editor it will fire the first time. Then try focusing the field, and without changing anything, blurring again, and the event will not fire. After that you can try adding 1234 to the field, and blurring (which will fire the alert), and then going back in to the field (clicking after the 4, not selecting any text) and hitting the backspace key. Then when you have 123 blur the editor and again the event will not fire.

I have reproduced this error with 4.2.2 and 4.3 beta, as well at the nightly updated on 01-Oct-2013 at 13:03 UTC. The same behavior exists on Chrome 29 on Windows 7, as well as Safari 5.1 for Mountain Lion.

Attached is an example file, but the easiest way to reproduce it is with the following code:

<textarea name="editor1"></textarea>

<script type="text/javascript">
	CKEDITOR.replace( 'editor1' );
	
	CKEDITOR.instances.editor1.on('blur', function() {
		alert('test');
	});
</script>

Attachments (1)

index.html (379 bytes) - added by nik 6 years ago.
Blur Test

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by nik

Attachment: index.html added

Blur Test

comment:1 Changed 6 years ago by nik

It appears as though the main issue is that when you click in the white space in an editor it does not always get focus and the blinking cursor does not show up in the editor, but you are still allowed to delete characters without the focus ever being set. Any other keystroke seems to give the editor focus.

comment:2 Changed 6 years ago by Jakub Ś

Status: newpending
Version: 4.2.2

I have tried clicking in various places of editor, using tab key and issue didn't occur.

I have tried this with CKEditor 4.2.2 and latest git on Chrome 30, Safari 5.05 on windows 7 and Safari 6 on mountain Lion. None of these browsers has shown problem. Could you please clear you cache, check it one more time and if possible provide test case scenario for reproducing and perhaps a screen cast?

NOTE: Not so long ago we had similar issue: #10908. User hasn't still replied.

comment:3 Changed 5 years ago by nik

Thank you for the response. This issue has been fixed with ticket #10945: [Chrome] Fixed: Clicking with a mouse inside the editor does not show the caret.

comment:4 Changed 5 years ago by nik

Resolution: fixed
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy