Opened 5 years ago

Closed 5 years ago

#11132 closed Bug (fixed)

[FF] Caret is lost (again) on FF after inline widget drop

Reported by: Piotrek Koszuliński Owned by: Piotrek Koszuliński
Priority: Must have (possibly next milestone) Milestone: CKEditor 4.3.1
Component: UI : Widgets Version:
Keywords: Cc:

Description

  1. Open placeholder sample.
  2. Drag widget.
  3. Click or press arrow keys - there's no caret. It can be restored after switching between modes or right click.

It's again the same bug in Gecko. Last time we added timeout before moving widget, but it does not help anymore.

We need a bug report on Bugzilla.

Change History (5)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Priority: NormalHigh
Status: newconfirmed

comment:2 Changed 5 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:3 Changed 5 years ago by Piotrek Koszuliński

Status: assignedreview

Unfortunately I wasn't able to limit the case to something we could attach in bug report. It's happening in a very specific situation, so I focused on bypassing this bug.

I pushed t/11132 with a patch. Previously we were delaying only the last phase, but since we're refocusing widget after drop, to save correct snapshot, we need to delay the whole process.

While working on this issue I noticed: #11198.

comment:4 Changed 5 years ago by Olek Nowodziński

Status: reviewreview_passed

While I find your patch quite obscure, it works and nothing seem to be broken :P

comment:5 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Fixed on master with git:4a28dcc.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy