Opened 6 years ago

Closed 4 years ago

Last modified 4 years ago

#11243 closed Bug (fixed)

Magicline and widgets

Reported by: Matti Järvinen Owned by:
Priority: Normal Milestone:
Component: UI : Widgets Version: 4.3
Keywords: Cc:

Description

I took the example widget from documentation (simplewidget) and noticed that it is possible to add new paragraphs with magickline into widgets non editable areas.

Changing this:

<div class="simplebox align-left" style="width: 500px;">
<h2 class="simplebox-title">Title</h2>

<div class="simplebox-content">
<p>Content...</p>
</div>
</div>

Into:

<div class="simplebox align-left" style="width: 500px;">
<h2 class="simplebox-title">Title</h2>

<div class="simplebox-content">
<p>Content...</p>
</div>

<p>&nbsp;</p>
</div>

Attachments (1)

example.png (12.5 KB) - added by Matti Järvinen 6 years ago.
Widget before and after using magic line.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by Matti Järvinen

Attachment: example.png added

Widget before and after using magic line.

comment:1 Changed 5 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 4 years ago by ferahl

Any update on this? I need magic line to help with widget spacing when a new line can't be created.. and yet it comes up inside the widgets themselves rendering it useless :(

Edit: seems to only happen with contenteditable="true" for me

Last edited 4 years ago by ferahl (previous) (diff)

comment:3 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.4

comment:4 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.4
Resolution: fixed
Status: confirmedclosed

As a matter of fact, we've checked this ticket and it turns out to be fixed in 4.4.2 by #12009. A pretty long time ago.

@ferahl: If you can still reproduce some issue, then please report a new ticket. Perhaps you have some different structure of the widget.

comment:5 Changed 4 years ago by ferahl

Ok will do, actually I could reproduce on a clean sandbox test on 4.5.3 if a div (which was not defined as an editable don't know if that made a difference) had contenteditable="true" --- I'll check again later and put a demo up

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy