Opened 5 years ago

Closed 5 years ago

#11289 closed Bug (invalid)

Codemirror source + undo / redo

Reported by: santaclaus21 Owned by:
Priority: Normal Milestone:
Component: Core : Undo & Redo Version:
Keywords: Cc:

Description (last modified by Piotrek Koszuliński)

orginal source:

<p>Z okazji zbliżających się Świąt Bożego Narodzenia - pragniemy życzyć Państwu....</p>
  • step 1 - backspace anywhere
  • step 2 - switch to source editing
  • step 3 - switch to normal editing mode
  • step 4 - undo

then source will be:

<p>Z okazji zbliżających się Świąt <span id="cke_bm_291C" style="display: none;">&nbsp;</span>o Narodzenia - pragniemy życzyć Państwu....</p>

or:

  • step 1: backspace anywhere
  • step 2: undo
  • step 3: switch to source

then:

<p>Z okazji <span id="cke_bm_381C" style="display: none;">&nbsp;</span>zbliżających się Świąt Bożego Narodzenia - pragniemy życzyć Państwu....</p>

I'm not pretty sure but it can be bug just in CodeMirror not in CKE.

Change History (2)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Description: modified (diff)

comment:2 Changed 5 years ago by Piotrek Koszuliński

Keywords: codemirror undo redo removed
Resolution: invalid
Status: newclosed
Version: 4.3

I'm not 100% sure, but I would say that it's a CodeMirror issue. I cannot reproduce anything similar with standard CKEditor build. In this case you can report this issue to the author of this plugin http://ckeditor.com/addon/codemirror.

Ekipa CKEditora życzy wesołych świąt :).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy