Opened 12 years ago

Closed 12 years ago

#1163 closed Bug (fixed)

On "New Page", a phantom cursor stays blinking

Reported by: Frederico Caldeira Knabben Owned by:
Priority: Normal Milestone: Opera Compatibility
Component: General Version:
Keywords: Cc: Hallvord R. M. Steen (Opera Software)

Description

Steps to Reproduce

  1. Open sample01.html;
  2. Hit enter at the end of the text to start a new paragraph;
  3. Type some text;
  4. Click the "New Page" button. Note that the cursor will continue blinking on the previous position, even if the editing are doesn't have the edit focus anymore;
  5. Click at the start of the editing area. The real cursor will start blinking there, but the old one will continue there.
  6. Hit enter once. The cursor will have a strange blinking effect, and the phantom cursor will disappear (I have the impression that both are in the same position now).
  7. Hit enter again. The phantom cursor will reappear one paragraph above the real one, and will follow it for every successive enter.
  8. Type some text. We are back to the situation described at point 6.

Change History (3)

comment:1 Changed 12 years ago by Hallvord R. M. Steen (Opera Software)

Fred: can't reproduce this one, what Opera build did you test with?

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

I can't reproduce it now. I have to get used to always include the build number on tests.

We are having a Focus issue now (#1273). The editing area is not anymore getting the focus when using toolbar buttons. I was wondering if this one is related to it.

So, let's close #1273 first, and hold on this one to check it right after that.

comment:3 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Ok... can't reproduce this one anymore.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy