Opened 5 years ago

Closed 5 years ago

#11680 closed Bug (duplicate)

Editor in Modal/Modeless dialog formatting problems

Reported by: Magnus Persson Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Browser: IE 10 and 11

Document mode: <meta http-equiv="X-UA-Compatible" content="IE=8" />

Problem description: When showing the editor in a Modal or Modeless dialog in Internet explorer 10 and 11 formatting is sometimes not applied and the wrong line is selected.

Reproduce: Create a page that opens a dialog with an editor: showModelessDialog('ShowEditor.html');

  1. Write two lines of text in the editor.
  2. Select the 2nd line and click on the Styles drop down and select Marker.
  3. Select the first line and click on the Italic button.

Expected: The first lines becomes italic.

Actual: The 2nd line becomes italic and selected.

Example: http://37.123.176.119/ckeditor/dialogerror.html

Change History (2)

comment:1 Changed 5 years ago by Magnus Persson

Summary: Editor in Modal/Modeless dilaog formatting problemsEditor in Modal/Modeless dialog formatting problems

comment:2 Changed 5 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed
Version: 4.3.3

DUP of #5406.

Currently there is no support for Modeless windows. Problems you experience are because of focus issues. There is however support for Modal Windows so I would recommend switching to Modals.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy