Opened 12 years ago

Closed 6 years ago

#1180 closed Bug (fixed)

'Print' button is always disabled.

Reported by: Aleksey Onopriyenko Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: Opera Cc: Hallvord R. M. Steen (Opera Software)

Description

'Print' button is always disabled.

Tested with Opera 9.5 (build 9500)

Change History (9)

comment:1 Changed 12 years ago by Hallvord R. M. Steen (Opera Software)

FCK.GetNamedCommandState expects queryCommandEnabled to throw an error rather than returning false when called with "Print"?

In any case, window.print does not work correctly in Opera. This is Opera's bug 29310 (oh yes, very old I know) and apparently it takes a large and serious rewrite to make window.print print only the frame it was called for.

If you want to fix this on your side, you'll have to move the document to a popup window and call popup.print(). (You may also need to work around the button being disabled - for example inside GetNamedCommandState you might detect Opera and the Print command and throw .. or something.)

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

We are prospecting leaving the button disabled for the 2.5, at least for the Beta. We have the same problem with Safari. Hallvord's suggestion, even if not the most elegant, is inspiring (we must remember that all styles must be loaded in the popup too).

For now, users will have the option to print from the "Preview" window.

comment:3 Changed 12 years ago by Wojciech Olchawa

Keywords: Confirmed added

comment:4 Changed 10 years ago by Artur Formella

The same bug occurs in CKEditor 3.0 beta 3667.

There is a workaround of this bug: open preview window and call print() function.

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Opera added

comment:6 Changed 9 years ago by Krzysztof Studnik

Version: 3.4.1 (SVN - trunk)

Confirmed for Opera 10.61.3484, CKE 3.4.1 Trunk

comment:7 Changed 7 years ago by Jakub Ś

#10524 was marked as duplicate.

This doesn't also work in CKEditor 4.x. I will need to look into this issue.

comment:8 Changed 6 years ago by Jakub Ś

Cc: Hallvord R. M. Steen (Opera Software) added
Version: 3.4.14.0

Ok It turns out it was enough to look into plugin code and google.

Opera doesn't allow printing iframed documents. Sample link: http://stackoverflow.com/questions/1648594/print-iframe-content-in-opera-and-chrome . For inline editor we haven't implemented this feature yet.

CKE code:

modes: { wysiwyg: !( CKEDITOR.env.opera ) } // It is impossible to print the inner document in Opera.

comment:9 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Fixed in Opera when it switched to Blink.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy