Opened 12 years ago

Closed 12 years ago

#1182 closed Bug (fixed)

Opera: deleting INPUT elements issue

Reported by: Aleksey Onopriyenko Owned by: Hallvord R. M. Steen (Opera Software)
Priority: Normal Milestone: Opera Compatibility
Component: General Version:
Keywords: Cc:

Description

Sometimes deleting of INPUT elements is non-trivial task.

Steps to reproduce.

  1. Load sample01.html
  2. Move cursor to the end of text.
  3. Insert checkbox (click on Checkbox button, fill the dialog fields and click Ok button).
  4. Hit Backspace in order to delete the checkbox. The checkbox is still there.

Now you can press Right Arrow key to place cursor after checkbox. Nothing happened. But you are able to do it with mouse. After that checkbox can be deleted pressing Backspace.

Instead of checbox another INPUT elements can be used to reproduce this bug.

Tested with Opera 9.50 (build 9500)

Change History (3)

comment:1 Changed 12 years ago by Aleksey Onopriyenko

Also an emoticon can be appended instead of checkbox in order to reproduce this bug.

comment:2 Changed 12 years ago by Hallvord R. M. Steen (Opera Software)

Owner: set to Hallvord R. M. Steen (Opera Software)
Status: newassigned

filed as Opera bug 286919, also see 286917 for related issue

comment:3 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Works for me with Opera build 9660.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy