Opened 6 years ago

Closed 5 years ago

#11845 closed Bug (expired)

Ckeditor Script time out on large amounts of data

Reported by: M Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Hi...

We are attempting to paste a table from Excel into a CKeditor RTF box. This box contains a large amount of data (when copied to MS Word the document is 45k with 8 pivot tables, one of whic is three pages long...and formatted text). When we copy a new pivot table from excel into the middle of the CKEditor RTF box, we get the 'A script on this page is causing your web browser to run slowly' error message. We get this message 4 times before the pivot table is successfully copied into the RTF box. When we attempt to paste the very same pivot table into a similar RTF box that contains no other data, the copy works fine. We are assuming that the amount of data in the first RTF box is the issue. Can you help?

Attachments (1)

PivotTable.png (22.0 KB) - added by M 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by M

Attachment: PivotTable.png added

comment:1 Changed 6 years ago by Jakub Ś

Status: newpending
  1. Please tell me which editor version you use
  2. Please provide data that is in editor when you paste
  3. Please provide excel file that you paste.
  4. Please tell us in which browsers you get this problem.

We will check this issue and then be able to give you any comment.

Please note that CKEditor is application working in a browser and there are some limits to amount of data you can put there. Even desktop applications like MS word have problems and require some time to e.g. open large files.

comment:2 Changed 6 years ago by M

Hi CKEditor Support...

Thanks for the response.

For your questions:

  1. CKEditor 3.6.2
  2. I'll try to provide data, but the exact data we are having trouble with contains proprietary information that I can't send out.
  3. Same as 2
  4. IE 8

I'll try to "dummy" up some data for you for questions 2 & 3

Last edited 6 years ago by Jakub Ś (previous) (diff)

comment:3 Changed 6 years ago by Jakub Ś

Thank you for information. First thing that strikes me is that you are still using old CKFinder 3.6.x which we don't support any more.

I would strongly recommend checking CKEditor 4.x. If issue doesn't occur there, you can overcome this problem by updating. If it does, we will try to provide fix but only for CKE 4.x.

If possible please provide some dummy data. This is crucial because without test data we won't be able to do anything.

comment:4 Changed 6 years ago by M

Thank you for the feedback! I will download CKEditor 4.x and see if that helps us. If that doesn't help, then I will work on the 'dummy' data. I'll let you know how 4.x goes. Thanks again

Last edited 6 years ago by M (previous) (diff)

comment:5 Changed 5 years ago by Piotrek Koszuliński

Resolution: expired
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy