Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12122 closed Bug (duplicate)

Deleting table in inline editor deletes or breaks editor

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0 Beta
Keywords: Support Cc: mike@…, satya_minnekanti@…

Description

Similar to #12110.

Problem can be reproduced in all browsers although results are different.

  1. Put sample html file in samples folder
  2. Open sample and click into table
  3. Right-click on table and select 'Delete Table'

Blink and Webkit - editor is no longer accessible (it disappears)
FF and IE - editable area disappears but toolbar remains. If you try to insert some element with it, JS error will be thrown.

Attachments (1)

editor.html (783 bytes) - added by Jakub Ś 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by Jakub Ś

Attachment: editor.html added

comment:1 Changed 5 years ago by Jakub Ś

NOTE: File has HTML4 docType declaration but the same thing is reproducible with HTML5 docType.

comment:2 Changed 5 years ago by Jakub Ś

Keywords: Support added
Status: newconfirmed

comment:3 Changed 5 years ago by Mike Burgh

Cc: mike@… added

comment:4 Changed 5 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

comment:5 Changed 5 years ago by Wiktor Walc

Milestone: CKEditor 4.4.3

Let's see what we can do with this.

comment:6 Changed 5 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.3
Resolution: duplicate
Status: confirmedclosed

This turned out to be a duplicate of #12110, for which we had a pull request. I'm closing this ticket as DUP, #12110 is fixed on master.

Last edited 5 years ago by Piotrek Koszuliński (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy