Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12128 closed Bug (invalid)

[Safari] Unable to Highlight and Delete 'contentEditable=false"

Reported by: Christophe Guillou Owned by:
Priority: Normal Milestone:
Component: General Version: 4.3 Beta
Keywords: IBM Cc: Irina, Satya Minnekanti

Description

Load the editor with HTML in Safari for OS X:

<p><span contenteditable="false">[[CONTENT]]</span></p>

Using the mouse, inside the wysiwyg editor select/highlight :

[[CONTENT]]

Hit backspace key.

-> issue :

[[CONTENT]] does not delete

Related to : https://dev.ckeditor.com/ticket/12121

Change History (2)

comment:1 Changed 5 years ago by Jakub Ś

Status: newpending

I wasn't able to reproduce this issue.

I have tried this TC in Safari 7 on Mac 10.9 and was able to delete contents every time. I have selected whole element with mouse (whole line got selected) and just hit backspace.

Is it possible that some custom modification or third party plugin is causing this?

If you are using non-standard build, could you attach your build-config.js.

comment:2 Changed 5 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed
Version: 4.3.24.3 Beta

I was able to reproduce this but only when I selected the non-editable element partially (but that's actually a correct solution). When selected entire line it can be deleted.

Please note that non-editable content is only supported inside editor in form of widgets. Browsers can't handle non-editable elements and therefore we created the widget system. This case would work perfectly with placeholder plugin (it uses the widget system).

I'm closing this ticket as invalid, because provided scenario bypasses widget system.

Last edited 5 years ago by Piotrek Koszuliński (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy