Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12536 closed Bug (invalid)

CKeditor Dropdowns reloading plugin issue

Reported by: Raghavan Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

When multiple dropdowns are on a same plugin, selecting value for one dropdown reloads the other dropdowns and dropdowns loses its state and selected value.

Attachments (1)

ckeditor.wrf (646.4 KB) - added by Raghavan 5 years ago.
webex file.

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by Raghavan

Attachment: ckeditor.wrf added

webex file.

comment:1 Changed 5 years ago by Jakub Ś

Status: newpending
Version: 4.4.5

Could you send something other than webex file? Preferably screen cast from Jing.

Additionally, could you send us reduced code for that plugin? I’m talking about something that can be used with default editor and will show this issue.

comment:2 Changed 5 years ago by Raghavan

there is no need for new plugin to reproduce this issue. This can be reproduced in ckedtitor demo page :)

  1. goto demo page
  2. select a italic title in style drop down
  3. Now click on Format dropdown. You will see the style drop down donot have italic style and got reloaded

Please confirm if you are not able to reproduce this issue. I can provide a jing cast

Last edited 5 years ago by Raghavan (previous) (diff)

comment:3 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

This is not how it works. Dropdown matches styled elements in editor. When you select italic title you are getting whole paragraph changed to H2 with font-syle:italic. When you select H1 from Format dropdown you whole line changes to H1 with font-syle:italic.
Such value is not available in styles dropdown thus dropdown returns to default value.

The issue you have reported is invalid.

NOTE: This issue is in some way related to one bug that this TC presents: #12526

comment:4 Changed 5 years ago by Raghavan

We have a plugin which was working with 4.0 where there are two dependent dropdowns the second value depends on first. This was working in previous versions which seems to be broke @ later releases.?

comment:5 Changed 5 years ago by Jakub Ś

So is this about styles/format dropdowns or dropdowns in custom plugin?

I have not seen your plugin but it is hard to treat questions about custom code as bugs. Could I ask you to provide simplified version of your plugin on support channel? If possible please also provide description explaining in step by step scenario how should your plugin work and what it the actual result.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy