Opened 4 years ago

Closed 4 years ago

#12724 closed New Feature (fixed)

Use notifications in upload widget

Reported by: Piotr Jasiun Owned by: Piotr Jasiun
Priority: Normal Milestone: CKEditor 4.5.0 Beta
Component: General Version:
Keywords: Cc:

Description (last modified by Piotrek Koszuliński)

Upload widget should use notifications instead of console to inform user about progress and warning.

The prefect solution would be to show one progress notification for multiple uploads.

TODO: Remove the console.log from the uploadwidget plugin.

Change History (7)

comment:1 Changed 4 years ago by Piotr Jasiun

Related: #11461, #11580.

comment:2 Changed 4 years ago by Piotrek Koszuliński

Description: modified (diff)
Status: newconfirmed

comment:3 Changed 4 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: confirmedassigned

comment:4 Changed 4 years ago by Piotr Jasiun

Status: assignedreview

Working on this ticket I found 3 related issues:

  • #12896, this branch is based on #12896, because otherwise behavior does not make sense,
  • #12901, creating tests it was very weird that upload needs to create two notifications,
  • git:7155887, notificationUpdate cancel behavior had to be changed, as described in docs and comment.

Changes are done and thanks to notification aggregator all uploads are displayed in one notification (excluding warning and success messages). Changes in t/12724.

comment:5 Changed 4 years ago by Piotrek Koszuliński

Status: reviewreview_failed

I pushed a rebased branch:t/12724 with some small corrections in docs and tests.

However, I spotted a bug. I opened http://tests.ckeditor.dev:1030/tests/plugins/uploadwidget/manual/image and dropped a file there. The progress goes to 13% and then I see a success message. The file I use has 74kb (1000/74 == 13).

comment:6 Changed 4 years ago by Piotr Jasiun

Status: review_failedreview

I pushed a changes in XHR mock so it works fine with every file size.

comment:7 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

Fixed on major with git:22b9485.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy