Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#12739 closed Bug (fixed)

Link loses inline styles when edited without dialogadvtab

Reported by: rory Owned by: Olek Nowodziński
Priority: Normal Milestone: CKEditor 4.4.8
Component: General Version: 4.4.3
Keywords: Cc:

Description

When editing a link, inline styles are stripped even when allowedContent = true.

This only affects the "standard" version, not the "full" version

To reproduce, right click on "Styled Link" and edit the URL

Standard 4.4.5, Issue present. http://jsfiddle.net/bdzht7p6/

Full 4.4.5, Issue NOT present. http://jsfiddle.net/xag8c1ow/

Change History (9)

comment:1 Changed 4 years ago by Piotrek Koszuliński

Component: Core : EditableGeneral
Status: newconfirmed
Version: 4.4.5

This happens due to the missing dialogadvtab (removeDialogTabs : 'link:advanced') plugin which is enabled in the full preset, but not in the standard one. So the quick workaround is to enable that plugin.

Without the plugin (and with the ACF off) it should not be possible to edit the link styles, but the link styles should not be lost when editing it.

Last edited 4 years ago by Jakub Ś (previous) (diff)

comment:2 Changed 4 years ago by Piotrek Koszuliński

Summary: Link plugin ignores allowedContent settingLink loses inline styles when edited without dialogadvtab

comment:3 Changed 4 years ago by Jakub Ś

Version: 4.4.3

Problem can be reproduced from CKEditor 4.4.3

comment:4 Changed 4 years ago by Jakub Ś

#12931 was marked as duplicate.

comment:5 Changed 3 years ago by Piotrek Koszuliński

comment:6 Changed 3 years ago by Olek Nowodziński

Owner: set to Olek Nowodziński
Status: confirmedreview

Changes in branch:t/12739. I simplified tests a little bit.

comment:7 Changed 3 years ago by Olek Nowodziński

Milestone: CKEditor 4.4.8

comment:8 Changed 3 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

Fixed on master with git:55a9c5b.

comment:9 Changed 3 years ago by Piotrek Koszuliński

It turned out that I haven't included a.nowodzinski's changes in tests, so I merged them now – git:445ff99.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy