Opened 5 years ago

Closed 5 years ago

#12931 closed Bug (duplicate)

CKEditor Strips <a> Style After Editing Link

Reported by: jmwright798 Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Descriptive Summary - CKEditor strips the inline "style" attribute for the <a> tag after using the "Edit Link" feature

Steps to Reproduce: Open an instance of the CKEditor with allowedContent set to "true". In the "Source" view, create a link with inline styles. For example:

<a href="http://foo.com" style="background-color:#111111;">test</a>

Then, in the "wysiwyg" view, right-click the link text and select "Edit Link"

Change the link href (optional!) and submit the change

The link now has had the styles removed.

Browser: Chrome OS: Win 8.1x64

Sample Data:

config.js: {

fullPage: true,

allowedContent: true

}

Build Configuration - Specfically, I'm integrating with Angular in my project, but this does not change the operation. This same behavior is found in the examples given on the site that disable the ACF.

Change History (6)

comment:1 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.4.7

I have checked this issue and haven't observed such behaviour in the editor.

Are you able to reproduce this issue when switching to source mode and back in default standalone editor (in both cases getData method is called so result will be the same)? If not then I would suspect your server-side code or some third-party JS in your application.

Please try it with editor as the standalone application and check what gets send in the request or what you see in source mode.

I'm closing this issue because I haven't been able to reproduce this problem if however you are able to provide steps to recreate it in standalone editor freshly downloaded from our page then I will reopen it.

comment:2 Changed 5 years ago by Piotrek Koszuliński

@j.swiderski: Please check http://stackoverflow.com/questions/28485331/ckeditor-strips-styles-when-editing-link - I was also able to reproduce it.

comment:3 Changed 5 years ago by Jakub Ś

I have used fullPage with allowedContent set to true.

I have done exactly what is written in @jmwright798 comment.

I have pasted the link, edited it (no change) switched to source (no change) or submitted form (no change in request params) In all cases link contains styles.

comment:4 Changed 5 years ago by jmwright798

@j.swiderski

Like @Reinmar, I have reproduced this issue using the test editor provided here that has fullPage and ACF disabled: http://cdn.ckeditor.com/4.4.7/standard/samples/plugins/magicline/magicline.html

To show my process more clearly, I have created a GIF of the steps here: https://i.imgur.com/P0fqaeh.gif

I appreciate the input and help so far! Let me know if you have any questions!

comment:5 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: closedreopened

Thank you for the details. I have managed to reproduce this problem however it doesn't have anything to do with the fullPage bur advanced tab in link.

This is a duplicate of #12739.

comment:6 Changed 5 years ago by Jakub Ś

Resolution: duplicate
Status: reopenedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy