Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12881 closed Bug (invalid)

Chrome bug :(

Reported by: Yunus ÖZ Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Hi; There is a button in my page, and when i press it i create these

  • a black and transparent div
  • a div for container for textarea
  • a textarea, and
  • a close button for remove all of these

when they created, i create your editor.

i send an ajax query in instanceReady event,

it is running with no error. when i click to close button i remove them completely, and press the button and create them again with no error again.

but in chrome, not show content in second time, cause of the not fired instanceReady

Sorry my english :(

Attachments (1)

CK_CHROME.js (6.8 KB) - added by Yunus ÖZ 4 years ago.
CKEDITOR_CHROME_LIGHTBOX

Download all attachments as: .zip

Change History (7)

comment:1 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.4.7

If i understand correctly and close button also closes the editor then you should destroy it when closing and create again when showing the editor.

In such case this is no Chrome or editor bug but error in implementation.

Changed 4 years ago by Yunus ÖZ

Attachment: CK_CHROME.js added

CKEDITOR_CHROME_LIGHTBOX

comment:2 Changed 4 years ago by Yunus ÖZ

i think, cant explain and i sent the js code which i told you. i hope it is clear for that

sorry english :(

comment:3 Changed 4 years ago by Yunus ÖZ

meanwhile, the code runs all browser with no problem, except chrome

comment:4 Changed 4 years ago by Jakub Ś

First of all this is not a forum but bug tracker so I will not continue this issue.

When looking at your code I didn't like the part with destroying the editor. Again first of all the destroy method works everywhere and you should not use remove or removing DOM nodes.
If X button removes all including the editor then the destroy editor method should be called inside method for X and not when editor is shown (it can be used in showEditor, just in case; but you should call editor creation after the instanceDestroyed event was fired).

comment:5 Changed 4 years ago by Yunus ÖZ

Heyy, if you dont agree the bugs, why u active this bug tracking system, i'm telling you what i see. and x button only destroy lightbox elements NOT EDITOR. please read it firstly i destroy it when calling showeditor func.

and try the codes, it is running or not. this is not funny for me, Thanks for help. and close the subject please pfff

comment:6 Changed 4 years ago by Jakub Ś

Heyy, if you dont agree the bugs, why u active this bug tracking system,

This is not a bug but error in your implementation, so bug report is invalid.

and x button only destroy lightbox elements NOT EDITOR. please read it firstly i destroy it when calling showeditor func.

It should destroy the editor. Your implementation is IMHO wrong at the moment.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy