Opened 4 years ago

Last modified 4 years ago

#13294 confirmed Bug

2 Buttons don't show in 'High Contrast Mode'; acessibility

Reported by: Arugula Owned by:
Priority: Normal Milestone:
Component: Accessibility Version:
Keywords: Cc:

Description

Hello, thanks for the most accessible editor anywhere! I can't use a CMS without it. BUT... a BUG: My eyesight requires the 'High Contrast Mode'. (info at: http://ckeditor.com/blog/CKEditor-WAI-ARIA-Usable-Accessibility

But two buttons don't work in this mode. In fact they don't show up at all, they dissapear:

'TextColor', 'BGColor' (background color button). Versions I tested with bug: 3.x to 4.4.7

Change History (11)

comment:1 Changed 4 years ago by Arugula

Component: GeneralAccessibility

comment:2 Changed 4 years ago by Piotrek Koszuliński

Keywords: acessibility High Contrast Mode removed
Status: newpending

Hey. I saw in code that color buttons are disabled in HC mode intentionally. I've tracked that this code comes from #3706 (see especially http://dev.ckeditor.com/ticket/3706#comment:5). Do you agree with this?

comment:3 Changed 4 years ago by Arugula

Thanks much for the info! And no, I definitely don't agree with penalizing disabled people by removing functions!! It has been causing a lot of havoc for me. Can can we get a patch for this? I use dark screens [high contrast], but I also need the access to color buttons at times, for highlighting, etc, in my documents. I doubt anyone would want the buttons removed, but if so, Ckeditor is already configurable to remove any buttons. But now, how do I get the buttons back? :( Thanks for your help.

comment:4 Changed 4 years ago by Arugula

Note: Like most people who use High Contrat Mode, I can still see, and see all colors. But for various reasons I can't use the normal browser color setup. However, I still need the 2 color buttons, and they could act normally.

comment:5 Changed 4 years ago by Piotrek Koszuliński

I totally agree with you that disabling the buttons does not make sense if they are in any way usable for your. I checked on IE8 in HC that colors are indeed totally invisible, so the color buttons would be hardly usable. Are in your environment the colors visible (other browser/OS0 or perhaps do you disable the HC mode from time to time? Could you tell us more about it? It would be easier for us to avoid such mistakes in the future.

As for the patch - it will be trivial. So as soon as we'll understand what's the situation, we'll fix this issue.

comment:6 Changed 4 years ago by Arugula

Thnaks! I do toggle off the HC for short times, when necessary. I set the Firefox browser with black screen and white text; and set other colors for the hyperlinks. Any pictures or images show up fine. Total white screens cause my eyes to cloud up and go temporarily blind, after just a few minutes. In the good old days buttons were made with tiny icon images, so I could see them. But now most site use css? Buttons? Anyway, I see empty these buttons as black squares. Except with ckeditor, which auto converts the buttons to text buttons. So if you could put those 2 buttons back in it would help. The buttons could be either text buttons, or regular icon buttons, either way would be better than nothing. (If the actual colors don't show up on black screens, then I guess I'll still have to toggle off the HC, but at least seeing the button there is a reminder. ) I guess it's tricky. Actual images of the colors would of course show up on all modes, but it might slow down Ckeditor? If so, perhaps a config optional version of ckeditr with the buttons as real images (rather than css colors). Thanks.

comment:7 Changed 4 years ago by Jakub Ś

Resolution: duplicate
Status: pendingclosed

@Arugula, we have reported a ticket for this case here: #13308.

Let's continue discussion there and I will close this ticket as duplicate.

comment:8 Changed 4 years ago by Piotrek Koszuliński

@Arugula: Thanks for the all the details. This is a really valuable feedback for us. For instance, I thought that we might try to use canvas - perhaps it will be displayed. And just one question - if canvas doesn't work, would color codes be of any value? In case nothing else work automatically, this would be the easiest solution.

Last edited 4 years ago by Piotrek Koszuliński (previous) (diff)

comment:9 Changed 4 years ago by Piotrek Koszuliński

Resolution: duplicate
Status: closedreopened

I would rather want to have this ticket opened, since it contains a lot of information already. I'm closing #13308 instead.

comment:10 Changed 4 years ago by Piotrek Koszuliński

Status: reopenedconfirmed

comment:11 Changed 4 years ago by Arugula

Hi Reinmar. Thanks for keeping this open. There was no reason to close it and start a whole new thread elsewhere.

What is 'Canvas'?? (a link to its info?). The more I thought about it overnight, I realized it might not quite help as much as I thought to have these buttons. Maybe I'll just need to toggle HC on/off when I need the color buttons. On the other hand, when hovering over the tiny colors (of the dropdown color chart) does show a hover tip with the name of the color. Ex: Cyan, Blue, Dim Gray, etc. And clicking the 'More colors' to bring up the larger dialog does show the hex value(color code). So that might be useful sometimes to some.

My suggestion now: a documented config setting in the .js or somewhere, that I or advanced users could edit to allow showing these 2 buttons even in HC mode. Even though colors might not show, the hover tips and hex values can be helpful. Thanks again!

Last edited 4 years ago by Arugula (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy