Opened 4 years ago

Closed 4 years ago

#13317 closed Task (fixed)

[Chrome] Native cut/copy/paste started working when triggered by a trusted event

Reported by: Piotrek Koszuliński Owned by: Artur Delura
Priority: Normal Milestone: CKEditor 4.5.0
Component: General Version:
Keywords: Cc:

Description

I'm not 100% sure yet, but it seems that the copy and cut buttons work. AFAICS paste doesn't but it's because we don't execute the native command (because it never worked) on other browsers than IE.

Following things need to be checked:

  • Whether I am correct.
  • Whether copy and cut commands trigger our listeners.
  • Whether we can make at least the normal paste work (paste as text and paste from word may be hard).

Change History (6)

comment:1 Changed 4 years ago by Wiktor Walc

comment:2 Changed 4 years ago by Jakub Ś

Status: newconfirmed

comment:3 Changed 4 years ago by Artur Delura

Owner: set to Artur Delura
Status: confirmedassigned

comment:4 Changed 4 years ago by Artur Delura

it seems that the copy and cut buttons work

According to this it works.

AFAICS paste doesn't

It doesn't - see here.

Whether I am correct.

You are correct :D

Whether copy and cut commands trigger our listeners.

// `type` is `cut` and `copy`.
editor.document.$.execCommand( type, false, null );

It directly fires native ClipboardEvent cut and copy on editable.

Whether we can make at least the normal paste work (paste as text and paste from word may be hard).

We can't because paste command doesn't work.

I created test for issue. Changes in branch:t/13317.

Last edited 4 years ago by Artur Delura (previous) (diff)

comment:5 Changed 4 years ago by Artur Delura

Status: assignedreview

comment:6 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

Merged to major with git:a4f0c97. I confirm your findings – paste indeed doesn't work now. But it's cool that copy and cut do. With the test we'll be able to check when something changes.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy