Opened 4 years ago

Closed 4 years ago

#13365 closed Bug (invalid)

[FF] Selection Field Properties tooltips alignment for bidi languages

Reported by: ACGC Owned by:
Priority: Normal Milestone:
Component: Core : BiDi Version:
Keywords: Cc:

Description

When opening the selection field properties form while using Arabic as a default language, the buttons' tooltips (Add, Modify, Up, Down) have Arabic text aligned to the left (LTR). While it should be aligned to the right.

Steps to reproduce to issue:

  1. Open the config.js file, and edit config.language field to 'ar'.
  2. Open CKeditor on Firefox browser.
  3. Click on selection field button.
  4. Hover over any of the form buttons (Add, Modify, up, Down).
  5. The text in the tooltip is aligned to the left.

Attachments (1)

tooltip.png (24.9 KB) - added by ACGC 4 years ago.
Snapshot for the tooltip text alignment for Arabic language.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by ACGC

Attachment: tooltip.png added

Snapshot for the tooltip text alignment for Arabic language.

comment:1 Changed 4 years ago by ACGC

Summary: [FF] Selection Field Properties tooltips alignment for bidi languages,[FF] Selection Field Properties tooltips alignment for bidi languages

comment:2 Changed 4 years ago by Jakub Ś

Keywords: bidi tooltip removed
Resolution: invalid
Status: newclosed
Version: 4.4.7
  1. I can't reproduce that. In my case in both Win and Mac tooltips took as much space as text so it was impossible to tell how text is aligned.
  2. Tooltips are handled by browser itself and not by the editor. The editor provides only text for the tooltip (title attribute inside 'a' element) while rest is done by the browser.

I don't see any problem with the editor here so I'm closing this issue as invalid.

@biditeam feel free to comment. Please also answer one very importan question - What was the language set in your operating system? Was it Arabic as well (this would indicate browser issue) or some LTR language like English (This would indicate invalid testing environment).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy