Opened 4 years ago

Closed 4 years ago

#13493 closed New Feature (wontfix)

Skin Builder app

Reported by: Steve James Owned by:
Priority: Normal Milestone:
Component: UI : Skins Version: 4.0
Keywords: Cc:

Description

I wanted to suggest that you consider creating an online skin builder web app, similar in concept to the jQuery UI Theme Roller app, http://jqueryui.com/themeroller/.

This could simplify the creation/update of editor skins and make it easier for those of us who would prefer not to have to get into the minutia details of your skin implementation to be able to more easily integrate the look of the editor with the rest of our websites.

A skin builder could also concatenate the various css files into a nice, tidy small set of files.

If you look at the way the jQuery UI Themeroller works, it basically produces two css files. One contains all the stylistic css rules, and the other contains all the "structural" css rules that are independent of the theme. It is a very nice, well organized package, that makes it simple to create and update themes. Plus, they will allow saving and loading a theme back to the app similar to how you do the CKBuilder load settings.

Obviously, you should do what makes most sense for CKEditor. However, I think having a skin builder app could be a benefit.

Change History (2)

comment:1 Changed 4 years ago by Jakub Ś

Keywords: skin builder app removed
Status: newconfirmed
Version: 4.6.0 (GitHub - major)4.0

Sounds like a nice feature but complicated one and the one we will not work on in the nearest future.

For simple color changes there is uiColor configuration property while for whole skin building process it would be nice to have something like template skin first (Please see #10964). Having such skin would open a way to create such feature.

NOTE: If there is anyone feeling strong enough to introduce such feature or the one mentioned in #10964, please feel free to submit a pull request.

Last edited 4 years ago by Jakub Ś (previous) (diff)

comment:2 Changed 4 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: confirmedclosed

This would definitely be a nice feature, but it must be taken into consideration from the very beginning, because the skin must be build around a set of values and relations between them. This is definitely something we are considering for CKEditor 5, e.g. because we [plan to use LESS](https://github.com/ckeditor/ckeditor5-design/issues/26), but this isn't something we can do for CKEditor 4 without rewriting the skin.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy